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O-03 (ANSYS) 
Формулировка задачи: 

Дано:  

E, ν=0,25 , 

F, l, d. 

Найти: 1) Коэффициенты канонического уравнения метода сил; 

2) Эпюры внутренних моментов (изгибающих и крутящих); 

2) Вертикальное перемещение точки К: δК ; 

Аналитический расчёт (см. O-03) даёт следующие решения: 
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Рис. 1. 
M  

 

Задача данного примера: при помощи ANSYS Multyphisics получить эти же 

результаты методом конечных элементов. 
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Предварительные настройки: 

Для решения задачи используется ANSYS Multiphysics 14.0: 

 

 

 

Utility Menu (U_M) 

Main Menu 

(M_M) 

Рабочее поле 

ANSYS Command Prompt (C_P) 

Кнопка 

Fit 

 

C меню M_M и U_M работают мышью, выбирая нужные опции. 

В окно C_P вручную вводят текстовые команды, после чего следует 

нажать на клавиатуре . 

Меняем чёрный цвет фона на белый следующими действиями: 

U_M > PlotCtrls > Style > Colors > Reverse Video 

В меню оставить только пункты, относящиеся к прочностным расчётам: 

M_M > Preferences > Отметить “Structural” > OK 

При построениях полезно видеть номера точек и линий твердотельной 

модели, узлов модели конечноэлементной: 

U_M > PlotCtrls > Numbering > 

Отметить KP, LINE, NODE ; 

Установить Elem на “No numbering”; 

Установить [/NUM] на “Colors & numbers”> OK 

Для большей наглядности увеличим размер шрифта: 

U_M > PlotCtrls > Font Controls > Legend Font > 

Установить «Размер» на «22»> OK 

U_M > PlotCtrls > Font Controls > Entity Font > 

Установить «Размер» на «22»> OK 

Предварительные настройки выполнены, можно приступать к решению задачи. 
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Решение задачи: 

Параметрам задачи, входящим в формулы (E, F, l, E, Iz) присваиваем значение 1. Тогда результатами расчёта будут 

коэффициенты перед формулами. Геометрическая жёсткость при кручении для круглых и кольцевых поперечных сечений 

ровно вдвое больше изгибного момента инерции. 

№ Действие Результат 

1 

Задаём параметры расчёта – базовые величины задачи: 

U_M > Parameters > Scalar Parameters > 

E=1       > Accept > 

F=1       > Accept > 

l=1       > Accept > 

d=0.13*l  > Accept > 

Iz=1      > Accept > 

Iy=Iz     > Accept > 

Ik=2*Iz   > Accept > 

ASect=1e6 > Accept > 

nu=0.25   > Accept > 

> Close 
 

2 

Первая строчка в таблице конечных элементов – балочный тип BEAM44: 

M_M  > Preprocessor 

C_P  > ET,1,BEAM44 >  

Посмотрим таблицу конечных элементов: 

M_M > Preprocessor > Element Type > Add/Edit/Delete > Close 

 



4 

http://www.tychina.pro/библиотека-задач-1/ 

№ Действие Результат 

3 

Реальные константы для элемента BEAM44: 

C_P > R,1,ASect,Iz,Iy,d,d,Ik >  

Посмотрим таблицу реальных констант: 

M_M > Preprocessor > Real Constants > Add/Edit/Delete > Close 

 

4 

Свойства материала стержня – модуль упругости и коэффициент Пуассона: 

M_M > Preprocessor > Material Props > Material Models > 

Structural > Linear > Elastic > Isotropic > 

В окошке EX пишем “E”, в окошке PRXY пишем “nu” 

> OK 

Закрываем окно «Deine Material Model Behavior». 
 

Основная система. Твердотельное моделирование: 

5 

Координаты узлов рамы A→1, Б→2, В→5, Г→6, Д→7, К→8: 

Создаём твердотельную модель основной системы (О.С.). 

Определяемся с положением рамы относительно глобальной декартовой системы 

координат. 
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№ Действие Результат 

6 

Ключевые точки : 

M_M> Preprocessor> Mоdeling> Create> Keypoints> In Active CS> 

NPT пишем 1 

X,Y,Z пишем   -l,0,0       > Apply > 

NPT пишем 2 

X,Y,Z пишем   -l,0,l      > Apply > 

NPT пишем 3 

X,Y,Z пишем         0,0,l      > Apply > 

NPT пишем 4 

X,Y,Z пишем         0,0,l      > Apply > 

NPT пишем 5 

X,Y,Z пишем    l,0,l      > Apply > 

NPT пишем 6 

X,Y,Z пишем    l,0,0      > Apply > 

NPT пишем 7 

X,Y,Z пишем  -2*l,0,l      > Apply > 

NPT пишем 8 

X,Y,Z пишем  2*l,0,l  > OK 

 

7 

Изометрия: 

Прорисовываем всё, что есть:  U_M > Plot > Multi-Plots 

 - изометрия; 

  - автоформат (размер изображения по размеру окна рабочего поля). 
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№ Действие Результат 

8 

Оcи стержней рамы: 

M_M > Preprocessor > Mоdeling > Create > Lines > Lines > 

Straight Line > 

Левой кнопкой мыши последовательно нажать на ключевые точки: 

1 и 2 

2 и 3(будет окошко выбора точек 3 или 4; выбрать 3 >OK>Apply) 

4(будет окошко выбора точек 3 или 4; выбрать 4 >OK) и 5 

6 и 5 

7 и 2 

5 и 8 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots  

9 

Заделки: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Displacement > On Keypoints > 

Левой кнопкой мыши нажать на 1 и 6 ключевые точки 

> OK > 

Lab2 установить “All DOF”  

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

Конечноэлементная модель основной системы. 

10 

Указываем материал, тип элементов и номер поперечного сечения: 

M_M > Preprocessor > Meshing > Mesh Attributes > All Lines > 

[TYPE]   установить “1 BEAM44” 

[MAT]    установить “1” 

[REAL]   установить “1” 

> OK  

11 

Размер элементов: 

Участки без распределённых нагрузок можно бить одним конечным элементом: 

M_M > Preprocessor > Meshing > Size Cntrls > ManualSize > 

Lines > All Lines > 

NDIV пишем 1 

> OK 

Обновляем изображение: U_M > Plot > Multi-Plots 

 

12 

Рабиваем линии на элементы: 

M_M > Preprocessor > Meshing > Mesh > Lines > Pick All 

Обновляем изображение: 

U_M > Plot > Multi-Plots  

Видим сразу две модели – твердотельную и конечноэлементную. 
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№ Действие Результат 

13 

Указываем, что именно нужно теперь прорисовывать по команде Multi-Plots: 

U_M > PlotCtrls > Multi-Plot Controls >  

Появляется первое окно Multi-Plotting > OK > 

Появляется второе окно Multi-Plotting > 

Оставляем в нём отметки только напротив Nodes и Elements 

> OK 

Обновляем изображение:  U_M > Plot > Multi-Plots  
Теперь видим только конечноэлементную модель. 

 

14 

Переносим на конечноэлементную модель нагрузки и закрепления с модели 

твердотельной: 

M_M > Loads > Define Loads > Operate > Transfer to FE > All 

Solid Lds > OK 

Обновляем изображение: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

Вычисление податливости δ11: 

15 

Единичные моменты по направлениям X1: 

Номера узлов здесь совпадают с номерами ключевых точек, 

потому, что одна линия – один элемент и линии проводились от 

ранних точек к поздним. 

Значит слева от разреза – узел №3, справа – узел №4: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Force/Moment > On Nodes > 

Левой кнопкой мыши отмечаем узел 3 (будет окошко выбора >OK) 

> OK > 

Lab установить “MZ” 

VALU пишем 1 

> Apply > 

Левой кнопкой мыши отмечаем узел 4 (будет окошко выбора >OK) 

> OK > 

Lab установить “MZ” 

VALU пишем -1 

> OK 

Обновляем изображение: U_M > Plot > Multi-Plots 

 

16 
Запускаем расчёт: 

M_M > Solution > Solve > Current LS > OK > OK 
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№ Действие Результат 

17 

Форма деформированной упругой оси рамы: 

M_M > General Postproc > Plot Results > 

> Deformed Shape > 

KUND установить Def + undeformed 

> OK  

 

 

18 

Перемещение узлов 3 и 4 по направлению X1 от единичной силы, приложенной к 

основной системе по этому же направлению: 

M_M > General Postproc > List Results > Nodal Solution > 

Nodal Solution > DOF Solution > Z-Component of rotation > OK 

Пропечаталась величина угла поворота левого узла (№3) в радианах: 

3
z

1ROTZ 2,25 ï î í àï ðàâëåí èþ X ,ò î åñò ü ï ðî ò èâ ÷àñî âî é ñò
l

ð ë
I

;
E

å êè 


  

Пропечаталась величина угла поворота правого узла (№4) в радианах: 

4
z

1ROTZ 2,25 ï î í àï ðàâëåí èþ X ,ò î åñò ü ï î ÷àñî âî é ñò
l

ð ë ;
E I

å êå 


  

Угол взаимного разворота узлов 3 и 4: 

11 3
z

4ROTZ ROTZ
E

;
I

4,5
l

 


   

Что в точности совпадает с результатом аналитического расчёта (см. рис. 1.).  
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№ Действие Результат 

Вычисление податливости δ1F: 

19 

Очистка модели от сосредоточенных сил: 

Обновляем изображение: 

U_M > Plot > Multi-Plots 

Силы и закрепления не пропали. Просто при расчёте меняются настройки 

видимости. Включаем изображение всех нагрузок и закреплений: 

U_M > PlotCtrls > Symbols > 

Селектор [/PBC] устанавливаем на “All Applied BCs” 

> OK 

Удаление внешних сосредоточенных сил и моментов: 

M_M > Preprocessor > Loads > Define Loads > Delete > 

Structural > Force/Moment > On Nodes > Pick All >  

Lab установить “All” 

> OK 

 

20 

Внешняя нагрузка, приложенная к основной системе: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Force/Moment > On Nodes > 

Левой кнопкой мыши отмечаем узлы 7 и 8 

> OK > 

Lab выбираем “FY” 

VALUE пишем -F 

> OK 

Обновляем изображение: U_M > Plot > Multi-Plots 
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№ Действие Результат 

21 
Запускаем расчёт: 

M_M > Solution > Solve > Current LS > OK > OK 

 

22 

Форма деформированной упругой оси рамы: 

M_M > General Postproc > Plot Results > Deformed Shape > 

KUND установить Def + undeformed 

> OK  

 

23 

Перемещение узлов 3 и 4 по направлению X1 от внешней нагрузки, приложенной к 

основной системе: 

M_M > General Postproc > List Results > Nodal Solution > 

Nodal Solution > DOF Solution > Z-Component of rotation > OK 

Пропечаталась величина угла поворота левого узла (№3) в радианах: 
2

3 1
z

ROTZ 1,25 ï î í àï ðàâëåí èþ X ,ò î åñò ü ï ðî ò èâ ÷àñî âî é
F l

ñò å
I

;
E

ð ëêè 





 

Пропечаталась величина угла поворота правого узла (№4) в радианах: 
2

4
z

1ROTZ 1,25 ï î í àï ðàâëåí èþ X ,ò î åñò ü ï î ÷àñî âî é
F l

ñò å ;
E

ëêå
I

ð


 


 

Угол взаимного разворота узлов 3 и 4: 

2

4
z

1F 3ROTZ ROTZ 2,5
E

;
F l

I
  





  

Что в точности совпадает с результатом аналитического расчёта (см. рис. 1.). 
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№ Действие Результат 

24 

Обновляем изображение: 

U_M > Plot > Multi-Plots 

U_M > PlotCtrls > Symbols > 

Селектор [/PBC] устанавливаем на “All Applied BCs” 

[/PSF] Surface Load Symbols устанавливаем “Pressures” 

> OK 

 

Расчётная схема рамы: 

25 

Связываем узлв 3 и 4 по всем степеням свободы: 

M_M > Preprocessor > Coupling/Ceqn > Coincident Nodes > 

Lab установить “All appropriate” 

TOLER оставить 0.0001 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 

 

26 
Запускаем расчёт: 

M_M > Solution > Solve > Current LS > OK > OK 
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№ Действие Результат 

27 

Силовая схема: 

U_M > PlotCtrls > Symbols > 

[/PBC] устанавливаем в положение “For Individual” 

Surface Load Symbols устанавливаем Pressures 

Show pres and convect as  устанавливаем  Arrows 

> OK > 

В окне “Applied Boundary Conditions” 

  U установить “Off” 

Rot установить “Off” 

  F установить “Symbol+Value” 

  M установить “Symbol+Value” 

> OK >  

В окне “Reactions”  

NFOR установить “Off” 

NMOM установить “Off” 

RFOR установить “Symbol+Value” 

RMOM установить “Symbol+Value” 

> OK 

В окне “Miscellaneous” поставить галочку на единственной позиции CP.  

Обновляем изображение: U_M > Plot > Multi-Plots 

Получаем тот же результат, что и на рис. 1. 

В рабочем поле видим следующее: 

- Красным цветом начерчены внешние силы; 

- Малиновым цветом - реактивные силы; 

- Фиолетовым - векторы реактивных моментов: изгибного (поперёк оси стержня) и 

крутильного (вдоль его оси). 
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№ Действие Результат 

28 

Вид сверху: 

 - вид сверху; 

  - автоформат (размер изображения по размеру окна рабочего поля). 

 

29 

Цветовая шкала будет состоять из десяти цветов: 

U_M > PlotCtrls > Style > Contours > Uniform Contours > 

NCONT пишем 10 

> OK 

 

30 

Составление эпюры внутреннего изгибающего момента Mизг: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “SMISC,”, “6” 

> Apply >  

“By sequence num”, “SMISC,”, “12” 

> OK > 

> Close 

Смотрим таблицу результатов: 

M_M > General Postproc > Element Table > Define Table > Close 
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№ Действие Результат 

31 

Прорисовка эпюры Mизг: 

M_M > General Postproc > Plot Results > Contour Plot > 

Line Elem Res > 

LabI установить “SMIS6” 

LabJ установить “SMIS12” 

Fact пишем 1 

> OK 

Получаем тот же результат, что и на рис. 1. (только числа, выделенные синим 

цветом). Значения показывает цветовая шкала.  

Цвет эпюры на центральной перекладине показывает значение в пятом слева 

интервале (0,5…0,6). Можно его уточнить (см. следующее действие).  

32 

Конечные элементы поперечины (между узлами 2 и 5): 

Выделяем нужные конечные элементы: 

U_M > Select > Entities >  

Устанавливаем “Elements”, “By Num/Pick” и “From Full” 

> OK 

Кликаем мышкой на элемент между узлами 2 и 3 

Кликаем мышкой на элемент между узлами 4 и 5 

> OK 

Прорисовываем: U_M > Plot > Replot 

Получаем тот же результат, что и на рис. 1. на участке Б-В (только числа, 

выделенные синим цветом). Значения показывает цветовая шкала. 

Выделяем сё, что есть: U_M > Select > Everything 

Прорисовываем: U_M > Plot > Replot 
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№ Действие Результат 

33 

Составление эпюры внутреннего крутящего момента Mкр: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “SMISC,”, “4” 

> Apply >  

“By sequence num”, “SMISC,”, “10” 

> OK > 

> Close 

Смотрим таблицу результатов: 

M_M > General Postproc > Element Table > Define Table > Close 
 

34 

Прорисовка эпюры Mкр: 

M_M > General Postproc > Plot Results > Contour Plot > 

Line Elem Res > 

LabI установить “SMIS4” 

LabJ установить “SMIS10” 

Fact пишем 1 

> OK 

Получаем тот же результат, что и на рис. 1. (только числа, выделенные синим 

цветом). Значения показывает цветовая шкала. 
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№ Действие Результат 

35 

Вертикальное перемещение узла №8 ( точка К) 

M_M > General Postproc > List Results > Nodal Solution > 

Nodal Solution > DOF Solution > Y-Component of displacement > 

> OK 

Получаем методом конечных элементов: 
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что в точности совпадает с результатом аналитического расчёта (рис. 1.). 
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Сохраняем проделанную работу: 

U_M > File > Save as Jobname.db 

Закройте ANSYS: 

U_M > File > Exit > Quit – No Save! > OK 

 

После выполнения указанных действий в рабочем каталоге остаются 

файлы с расширениями “.BCS”, “.db”, “.emat”, “.err”, “.esav”, “.full”, “.log”, 

“.mntr”,  “.rst”, ”.stat” и “SECT”. 

Интерес представляют “.db” (файлы модели), “.rst” (файл результатов 

расчёта) и файл “.SECT” (поперечное сечение), остальные файлы 

промежуточные, их можно удалить. 

 


