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M-03 (ANSYS) 

Формулировка задачи: 

Дано: E, Iz, F, l. 

Односвязная плоская рама, 

нагруженная сосредоточенными 

силами F. 

E – модуль упругости материала; 

IZ – изгибный момент инерции. 

Найти: Эпюру внутреннего изгибающего момента MZ; 

Коэффициенты канонических уравнений δij и неизвестные Xi при 

раскрытии статической неопределимости путём назначения 

избыточными внешних связей в точке И. 

Аналитический расчёт (см. M-03) даёт следующие решения: 

Суммарная эпюра внутреннего изгибающего момента: 
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 Рис. 1. 
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При решении задачи избыточными назначались внешние связи в точке И: 
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Рис. 2. 

Задача данного примера: при помощи ANSYS Multyphisics получить эти же 

результаты методом конечных элементов. 
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Предварительные настройки: 

Для решения задачи используется ANSYS Multiphysics 14.0: 
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C меню M_M и U_M работают мышью, выбирая нужные опции. 

В окно C_P вручную вводят текстовые команды, после чего следует 

нажать на клавиатуре . 

Меняем чёрный цвет фона на белый следующими действиями: 

U_M > PlotCtrls > Style > Colors > Reverse Video 

В меню оставить только пункты, относящиеся к прочностным расчётам: 

M_M > Preferences > Отметить “Structural” > OK 

При построениях полезно видеть номера точек и линий твердотельной 

модели: 

U_M > PlotCtrls > Numbering > 

Отметить KP, LINE ; 

Установить Elem на “No numbering”; 

Установить [/NUM] на “Colors & numbers”> OK 

Для большей наглядности увеличим размер шрифта: 

U_M > PlotCtrls > Font Controls > Legend Font > 

Установить «Размер» на «22»> OK 

U_M > PlotCtrls > Font Controls > Entity Font > 

Установить «Размер» на «22»> OK 

Предварительные настройки выполнены, можно приступать к решению задачи. 
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Решение задачи: 

Приравняв E, IZ, F и l к единице, результаты получим в виде чисел, обозначенных на рис. 1. синим цветом. 

№ Действие Результат 

1 

Задаём параметры расчёта – базовые величины задачи: 

U_M > Parameters > Scalar Parameters > 

E=1   > Accept > 

A=1e6  > Accept > 

Iz=1   > Accept > 

F=1    > Accept > 

l=1    > Accept > 

nu=0.3 > Accept > 

> Close  

2 

Первая строчка в таблице конечных элементов – плоский балочный тип BEAM3: 

M_M  > Preprocessor 

C_P  > ET,1,BEAM3 >  

Посмотрим таблицу конечных элементов: 

M_M > Preprocessor > Element Type > Add/Edit/Delete > Close 
 

3 

Первая строчка в таблице параметров («реальных констант») выбранного типа 

конечного элемента:площадь поперечного сечения = A;момент инерции = Iz; высота 

= l/100. 

C_P > R,1,A,Iz,L/100 >  

Посмотрим таблицу реальных констант: 

M_M > Preprocessor > Real Constants > Add/Edit/Delete > Close 
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№ Действие Результат 

4 

Свойства материала стержня – модуль упругости и коэффициент Пуассона: 

M_M > Preprocessor > Material Props > Material Models > 

Structural > Linear > Elastic > Isotropic > 

В окошке EX пишем “E”, в окошке PRXY пишем “nu” > OK 

Закрываем окно «Deine Material Model Behavior».  

Твердотельное моделирование 

5 

Координаты узлов рамы: 

Определяемся с положением рамы относительно глобальнй декартовой системы 

координат. 
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Ключевые точки – границы участков: A 1, Б 2, В 3, Г 4, Д 5, И 6 : 

M_M> Preprocessor> Mоdeling> Create> Keypoints> In Active CS> 

NPT пишем 1 

X,Y,Z пишем 0, -l,0 > Apply > 

NPT пишем 2 

X,Y,Z пишем l,·-l,0 > Apply > 

NPT пишем 3 

X,Y,Z пишем l,0,0 > Apply > 

NPT пишем 4 

X,Y,Z пишем 2·l,0,0 > Apply > 

NPT пишем 5 

X,Y,Z пишем 2·l, -l,0 > OK 

NPT пишем 6 

X,Y,Z пишем  3·l, -l,0 > OK 

Прорисовываем всё, что есть: U_M > Plot > Multi-Plots 
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№ Действие Результат 

7 

Пять участков  –  пять линии: 

M_M > Preprocessor > Mоdeling > Create > Lines > Lines > 

Straight Line > 

Левой кнопкой мыши последовательно нажать на ключевые точки: 

1 и 2  

2 и 3  

3 и 4  

4 и 5  

5 и 6  

> OK 

Прорисовываем всё, что есть: 
 U_M > Plot > Multi-Plots  

8 

Заделки: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Displacement > On Keypoints > 

Левой кнопкой мыши нажать на 1 и 6 ключевые точки 

> OK > 

Lab2 установить “All DOF” 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

9 

Нагрузка: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Force/Moment > On Keypoints > 

Левой кнопкой мыши нажать на 3 и 4 ключевые точки 

> OK > 

Lab установить “FX” 

VALU пишем F 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 

 

Конечноэлементная модель 

10 

Указываем материал, реальные константы и тип элементов: 

M_M > Preprocessor > Meshing > Mesh Attributes > All Lines > 

MAT установить “1” 

REAL установить “1” 

TYPE установить “1 BEAM3” 

> OK 
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№ Действие Результат 

11 

Стержень без распределённой нагрузки можно бить одним конечным элементом, 

но при вычислении коэффициентов канонических уравнений для наглядности будет 

прорисовываться форма деформированной оси рамы, поэтому каждый участок 

лучше разбить несколькими балочными конечными элементами: 

M_M > Preprocessor > Meshing > Size Cntrls > ManualSize > 

Lines > All Lines > 

NDIV пишем 10  

> OK 

Обновляем изображение: U_M > Plot > Multi-Plots 

 

12 

Указываем, что именно нужно теперь прорисовывать по команде Multi-Plots: 

U_M > PlotCtrls > Multi-Plot Controls… >  

Появляется первое окно Multi-Plotting 

> OK > 

Появляется второе окно Multi-Plotting > 

Оставляем в нём отметки только напротив Nodes и Elements 

> OK 
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№ Действие Результат 

13 

Рабиваем линии на элементы: 

M_M > Preprocessor > Meshing > Mesh > Lines > Pick All 

Обновляем изображение: 

U_M > Plot > Multi-Plots 

Бирюзовым цветом изображены балочные элементы. Чёрные точки – 

это их узлы. 

 

14 

Переносим на конечноэлементную модель нагрузки и закрепления с модели 

твердотельной: 

M_M > Loads > Define Loads > Operate > Transfer to FE > All 

Solid Lds 

> OK 

 

Расчёт 

15 

Запускаем расчёт: 

M_M > Solution > Solve > Current LS 

Синхронно появляются два окна: белое информационное и серое исполнительное. 

Белое закрываем, на сером нажимаем OK. Расчёт пошёл. Ждём. 

Появится окно «Solution is done!». Закройте это окно. Расчёт окончен. 
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№ Действие Результат 

Просмотр результатов 

16 

Силовая схема: 

U_M > PlotCtrls > Symbols > 

[/PBC] устанавливаем в положение “For Individual” 

Убираем галочку с “Miscellaneous” 

Surface Load Symbols устанавливаем Pressures 

Show pres and convect as устанавливаем Arrows > OK >  

В окне “Applied Boundary Conditions” 

  U установить “Off” 

Rot установить “Off” 

  F установить “Symbol+Value” 

  M установить “Symbol+Value” 

> OK >  

В окне “Reactions”  

NFOR установить “Off” 

NMOM установить “Off” 

RFOR установить “Symbol+Value” 

RMOM установить “Symbol+Value” 

> OK 

Обновляем изображение: U_M > Plot > Elements 

 - изометрия;   - автоформат. 

Полное совпадение силовой схемы с рис. 1 .(числа, выделенные синим цветом) за 

исключением реактивных моментов: Δ=(0,365-0,364)/0,365*100%=0,3%. 

В рабочем поле видим следующее: 

- Красным цветом начерчены внешние силы; 

- Фиолетовым цветом - вектора реактивных моментов; 

- Малиновым цветом нарисованы реактивные силы. 
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№ Действие Результат 

17 

Возвращаемся к фронтальному виду: 

 - вид спереди; 

  - автоформат (размер изображения по размеру окна рабочего поля). 

 

18 

Цветовая шкала будет состоять из десяти цветов: 

U_M > PlotCtrls > Style > Contours > Uniform Contours > 

NCONT пишем 10 

> OK 

 

19 

Составление эпюры внутреннего изгибающего момента: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “SMISC,”, “6” 

> Apply >  

“By sequence num”, “SMISC,”, “12” 

> OK > 

> Close 

Смотрим таблицу результатов: 

M_M > General Postproc > Element Table > Define Table > Close 
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№ Действие Результат 

20 

Прорисовка эпюры внутреннего изгибающего момента: 

M_M > General Postproc > Plot Results > Contour Plot 

> Line Elem Res > 

LabI установить “SMIS6” 

LabJ установить “SMIS12” 

Fact пишем 1 

> OK  

Сравниваем с рис.1. 

В точках А и И высота эпюры равна значениям реактивных моментов ( 0,364 ); в 

точках Б и Д высота эпюры 0,545 (это видно по цветовой шкале). Высоты эпюры в 

точках В и Г можно определить лишь приблизительно, по их попаданию в 

соответствующий цветовой интервал.  

21 

Участок между точками В и Г: 

Выделяем конечные элементы участка: 

U_M > Select > Entities >  

Устанавливаем “Elements” и “By Num/Pick” 

Селектор на “From Full” 

> OK 

Последовательно кликаем левой кнопкой мыши на каждый из 

десяти элементов 

> OK 

Прорисовываем: U_M > Plot > Replot 

Виден тот же результат, что и на рис. 1. на участке B-Г ( 0,454 ). Значения показывает 

цветовая шкала. 

Выделяем сё, что есть: U_M > Select > Everything 

Прорисовываем: U_M > Plot > Replot 
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№ Действие Результат 

22 

Прорисовываем закрепления и  внешние силы: 

U_M > PlotCtrls > Symbols > 

[/PBC] устанавливаем в положение “For Individual” 

Убираем галочку с “Miscellaneous” 

Surface Load Symbols устанавливаем Pressures 

Show pres and convect as устанавливаем Arrows > OK >  

В окне “Applied Boundary Conditions” 

  U установить “Symbol” 

Rot установить “Symbol” 

  F установить “Symbol+Value” 

  M установить “Symbol+Value” > OK >  

В окне “Reactions”  

NFOR установить “Off” 

NMOM установить “Off” 

RFOR установить “Off” 

RMOM установить “Off” > OK 

Обновляем изображение: U_M > Plot > Multi-Plots 

 

23 

Убираем заделку в точке И, получается ОС с приложенной внешней нагрузкой: 

M_M > Preprocessor > Loads > Define Loads > Delete > 

Structural > Displacement > On Keypoints > 

Левой кнопкой мыши нажать на точку с правой заделкой 

> OK > 

Lab DOFs to be deleted установить “All DOF” 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

24 
Расчёт : 

M_M > Solution > Solve > Current LS > OK > Close 
 

25 

Деформированная форма: 

M_M > General Postproc > Plot Results > 

Deformed Shape > 

KUND установить Def + undeformed 

> OK 

Ни сил ни заделок не видно, поэтому повторяем также действие 

№23. 

Видим недеформированную форму упругой оси рамы (чёрная) и 

деформированную форму (синяя) в некотором масштабе.  

26 

Выделяем узел в точке И: 

U_M > Select > Entities >  

Устанавливаем “Nodes”, “By Num/Pick” и “From Full” 

> OK 

Кликаем на крайнюю правую точку деформированной формы 

В окошке Select nodes припишется номер узла «Node No. = 42» 

> OK 

    Узел 
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№ Действие Результат 

27 

Податливости δ1F, δ2F , и δ3F: 

Линейные перемещения узла №42: 

M_M > General Postproc > List Results > Nodal Solution > 

Nodal Solution > DOF Solution > Displacement vector sum> 

> OK 

Видим: 
3

F
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F l

E
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Что полностью совпадает с результатами, представленными на рис.2.
 

Угловое перемещение узла №42: 

M_M > General Postproc > List Results > Nodal Solution > 

Nodal Solution > DOF Solution > Z-Component of rotation > 

> OK 

Видим: 

3F

2

x

F l

E I
ROTZ 3 3 .    




  

И тут совпадение с  рис.2. налицо.
 

Выделяем сё, что есть: U_M > Select > Everything 
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№ Действие Результат 

28 

Подготовка модели – ОС, нагруженная единичной силой по первому направлению: 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots  

Очистка прошлой нагрузки: 

M_M > Preprocessor > Loads > Define Loads > 

Delete > Structural > Force/Moment > On 

Keypoints > Pick All > 

Lab установить All 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots  

Единичная сила по первому направлению: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Force/Moment > On Nodes > 

Левой кнопкой мыши нажать на узел №42 (в точке И) 

> OK > 

Lab установить “FX” 

VALU пишем 1 

> OK 

Возникнет предупреждающее окно, закройте его. 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

29 
Расчёт : 

M_M > Solution > Solve > Current LS > OK > Close 
 

30 

Деформированная форма: 

M_M > General Postproc > Plot Results > 

Deformed Shape > 

KUND установить Def + undeformed 

> OK 

Ни сил ни заделок не видно, поэтому повторяем также действие 

№23. 

Видим недеформированную форму упругой оси рамы (чёрная) и 

деформированную форму (синяя) в некотором масштабе. 

 

31 

Выделяем узел в точке И: 

U_M > Select > Entities >  

Устанавливаем “Nodes”, “By Num/Pick” и “From Full” 

> OK 

Кликаем на крайнюю правую точку деформированной формы 

> OK 
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№ Действие Результат 

32 

Податливости δ11, δ21 , и δ31: 

Линейные перемещения узла №42: 

M_M > General Postproc > List Results > Nodal Solution > 

Nodal Solution > DOF Solution > Displacement vector sum> 

> OK 

Видим: 

11
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x
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l
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l
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Полное совпадение с рис.2.
 

Угловое перемещение узла №42: 

M_M > General Postproc > List Results > Nodal Solution > 

Nodal Solution > DOF Solution > Z-Component of rotation > 

> OK 

Видим: 

31

2

x

ROTZ 2 2
E I

.
l

  


  

Полное совпадение с  рис.2.
 

Выделяем сё, что есть: U_M > Select > Everything 
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№ Действие Результат 

33 

Подготовка модели – ОС, нагруженная единичной силой по второму направлению: 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots  

Очистка прошлой нагрузки: 

M_M > Preprocessor > Loads > Define Loads > Delete > 

Structural > Force/Moment > On Nodes > Pick All > 

Lab установить All 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots  

Единичная сила по второму направлению: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Force/Moment > On Nodes > 

Левой кнопкой мыши нажать на узел №42 (в точке И) 

> OK > 

Lab установить “FY” 

VALU пишем 1 

> OK 

Если возникнет предупреждающее окно, закройте его. 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

34 
Расчёт : 

M_M > Solution > Solve > Current LS > OK > Close 
 

35 

Деформированная форма: 

M_M > General Postproc > Plot Results > 

Deformed Shape > 

KUND установить Def + undeformed 

> OK 

Ни сил ни заделок не видно, поэтому повторяем также действие 

№23. 

Видим недеформированную форму упругой оси рамы (чёрная) и 

деформированную форму (синяя) в некотором масштабе. 

 

36 

Выделяем узел в точке И: 

U_M > Select > Entities >  

Устанавливаем “Nodes”, “By Num/Pick” и “From Full” 

> OK 

Кликаем на крайнюю правую точку деформированной формы 

> OK 
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№ Действие Результат 

37 

Податливости δ22 и δ32: 

Линейные перемещения узла №42: 

M_M > General Postproc > List Results > Nodal Solution > 

Nodal Solution > DOF Solution > Displacement vector sum> 

> OK 

Видим: 

2

3

2

x

UY 14 1
E I

4 .
l

 


   

Полное совпадение с рис.2.
 

Угловое перемещение узла №42: 

M_M > General Postproc > List Results > Nodal Solution > 

Nodal Solution > DOF Solution > Z-Component of rotation > 

> OK 

Видим: 

32

2

x

ROTZ 7,5 7,5 .
l

E I
  


  

Полное совпадение с  рис.2.
 

Выделяем сё, что есть: U_M > Select > Everything 
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№ Действие Результат 

38 

Подготовка модели – ОС, нагруженная единичной силой по третьему направлению: 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots  

Очистка прошлой нагрузки: 

M_M > Preprocessor > Loads > Define Loads > Delete > 

Structural > Force/Moment > On Nodes > Pick All > 

Lab установить All 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots  

Единичный момент по третьему направлению: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Force/Moment > On Nodes > 

Левой кнопкой мыши нажать на узел №42 (в точке И) 

> OK > 

Lab установить “MZ” 

VALU пишем 1 

> OK 

Если возникнет предупреждающее окно, закройте его. 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 

Для лучшего просмотра посмотрите на модель в изометрии, потом 

вернитесь к фронтальному виду: 

 - изометрия;  - фронтальный вид. 
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№ Действие Результат 

39 
Расчёт : 

M_M > Solution > Solve > Current LS > OK > Close 
 

40 

Деформированная форма: 

M_M > General Postproc > Plot Results > 

Deformed Shape > 

KUND установить Def + undeformed 

> OK 

Ни сил ни заделок не видно, поэтому повторяем также действие 

№23. 

Видим недеформированную форму упругой оси рамы (чёрная) и 

деформированную форму (синяя) в некотором масштабе. 

 

41 

Выделяем узел в точке И: 

U_M > Select > Entities >  

Устанавливаем “Nodes”, “By Num/Pick” и “From Full” 

> OK 

Кликаем на крайнюю правую точку деформированной формы 

> OK 
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№ Действие Результат 

42 

Податливость δ33 : 

Угловое перемещение узла №42: 

M_M > General Postproc > List Results > Nodal Solution > 

Nodal Solution > DOF Solution > Z-Component of rotation > 

> OK 

Видим: 

33

x

ROTZ 5 5
l

E I
.  


  

Полное совпадение с  рис.2.
 

Выделяем сё, что есть: U_M > Select > Everything 
 

 



25 

http://www.tychina.pro/библиотека-задач-1/ 

Сохраняем проделанную работу: 

U_M > File > Save as Jobname.db 

Закройте ANSYS: 

U_M > File > Exit > Quit – No Save! > OK 

 

После выполнения указанных действий в рабочем каталоге остаются 

файлы с расширениями “.BCS”, “.db”, “.emat”, “.err”, “.esav”, “.full”, “.log”, 

“.mntr”,  “.rst” и ”.stat”. 

Интерес представляют “.db” (файл модели) и “.rst” (файл результатов 

расчёта), остальные файлы промежуточные, их можно удалить. 

 

 


