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I-03 (ANSYS) 
Формулировка задачи: 

Консольный стержень треугольного 

поперечного сечения нагружена 

внешним изгибающим моментом М 

на конце. 

E – модуль упругости материала; 

1) Главные осевые моменты инерции поперечного сечения IX и IY ; 

2) Внутренние изгибающие моменты MX  и MY  в сечениях бруса; 

3) Эпюру распределения нормальных напряжений в сечениях бруса. 

Аналитический расчёт (см. I-03) даёт следующие решения: 
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Главные моменты инерции  : 
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Задача данного примера: при помощи ANSYS Multyphisics получить эти же 

результаты методом конечных элементов. 
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Дано: 

Найти: 

http://www.tychina.pro/app/download/7960954893/I-03.pdf?t=1421405519
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Предварительные настройки: 

Для решения задачи используется ANSYS Multiphysics 14.0: 

 

 

 

Utility Menu (U_M) 

Main Menu 

(M_M) 

Рабочее поле 

ANSYS Command Prompt (C_P) 

Кнопка 

Fit 

 

C меню M_M и U_M работают мышью, выбирая нужные опции. 

В окно C_P вручную вводят текстовые команды, потом . 

 

Меняем чёрный цвет фона на белый следующими действиями: 

U_M > PlotCtrls > Style > Colors > Reverse Video 

Оставить в меню пункты, относящиеся только к прочностным расчётам: 

M_M > Preferences > Отметить “Structural” > OK 

Нумеровать ключевые точки, линии, узлы и элементы: 

U_M > PlotCtrls > Numbering > 

Отметить KP, LINE, NODE 

Установить Elem на “Element numbers” 

Установить [/NUM] на “Colors & numbers” > OK 

Будем работать с локальными системами координат. Прорисовывать их: 

U_M > PlotCtrls > Symbols > 

Boundary condition symbol устанавливаем в положение“All Applied BCs” 

Surface Load Symbols      устанавливаем в положение“Pressure” 

Show pres and convect ass устанавливаем в положение“Arrows” 

CS                        устанавливаем в положение“on” 

> OK 

Для большей наглядности увеличим размер шрифта: 

U_M > PlotCtrls> Font Controls> Legend Font> «Размер» на «22» > OK 

U_M > PlotCtrls> Font Controls> Entity Font> «Размер» на «22» > OK 

Предварительные настройки выполнены, можно приступать к решению задачи.
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Решение задачи:  Приравняв E, a, P и l к единице, результаты получим в виде чисел, обозначенных на рис. 1. синим цветом  

№ Действие Результат 

1 

Задаём параметры расчёта – базовые величины задачи: 

U_M > Parameters > Scalar Parameters > 

a=1 > Accept > 

E=1 > Accept > 

l=1 > Accept > 

M=1 > Accept > 

nu=0.3 > Accept > 

> Close  

2 

Первая строчка в таблице конечных элементов – трёхмерный балочный BEAM188: 

M_M > Preprocessor > Element Type > Add/Edit/Delete > Add 

Element reference number пишем 1 

В левом окошке выбираем “Beam” 

В правом окошке “2 node 188” 

> OK > 

В окошке Element types отметить строчку “1 BEAM188” 

> Options > 

K3 установить “Quadradic Form” 

> OK > 

> Close 

 

3 

Свойства материала стержня – модуль упругости и коэффициент Пуассона: 

M_M > Preprocessor > Material Props > Material Models > 

Structural > Linear > Elastic > Isotropic > 

EX пишем “E”, 

PRXY пишем “nu” 

> OK 

Закрываем окно«Deine Material Model Behavior».  
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№ Действие Результат 

Поперечное сечение 

4 

Поверхность поперечного сечения: 

Угловые точки: 

M_M> Preprocessor> Mоdeling> Create> Keypoints> In Active CS> 

NPT пишем 1 

X,Y,Z пишем 0,0,0 > Apply > 

NPT пишем 2 

X,Y,Z пишем a,0,0 > Apply > 

NPT пишем 3 

X,Y,Z пишем 0, a, 0 > OK 

Строим плоскую поверхность по угловым точкам: 

M_M > Preprocessor > Mоdeling > Create > Areas > Arbitrary > 

Through KPs >  

Левой кнопкой мыши последовательно кликните на точки 1, 2 и 3 

> OK  

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

5 

Геометрические характеристики начерченной поверхности: 

M_M > Preprocessor > Modeling > Operate > Calc Geom Items > 

Of Areas > 

Переключатель Selection устанавливаем как “Normal” 

> OK 

Получаем:
C C Cx 0.3333 ; y 0.3333 ; z 0    - координаты центра тяжести; 

THXY 45 ;THYZ 0 ;THZX 0   - углы перехода от глобальной декартовой 

системы координат к системе координат главных центральных осей; 

Для того, чтобы увидеть главные центральные оси, позиционируем по ним систему 

координат рабочей плоскости: 

U_M  > WorkPlane > Display Working Plain 

U_M  > WorkPlane > Offset WP by Increments > 

В окошке “X,Y,Z Offsets” пишем координаты центра 0.3333,0.3333,0 

В окошке “XY,YZ,ZX Angles” пишем угол перехода 45,0,0 

> OK 

Видим: положение центра тяжести поверхности и 

направления её главных центральных осей совпадают с 

указанными на рис.1. Наименования осей иные, но это не 

принципиально. Просто рассмотрим пропечатанные моменты 

инерции, как момент относительно оси параллельной ( ) и 

момент относительно оси перпендикулярной ( ) длинной 

стороне фигуры: 

0I , 1XX 67I 04    

0I , 3YY 89I 01   

Эти результаты совпадают с приведенными на рис.1. (числа, выделенные синим 

цветом) c моментами xI  и yI  соответственно. 

 

 

y x 

I  I  
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№ Действие Результат 

6 

Главные центральные оси поперечных сечений (система координат №11): 

Перед тем, как создавать систему координат, переименуем оси в соответствии с 

рис.1. Поворачиваем рабочую плоскость так, чтобы  X  и  Y  поменялись местами: 

U_M  > WorkPlane > Offset WP by Increments > 

Три раза нажимаем кнопку  

> OK 

Декартову систему координат №11 (главные центральные оси поперечных сечений 

стержня) создаём по системе координат рабочей плоскости: 

U_M > WorkPlane> Local Coordinate Systems> 

> Create Local CS> At WP Origin>  

KCN пишем 11 

KCS устанавливаем Cartesian (декартова) 

> OK 

Гасим оси координат рабочей плоскости: 

U_M > WorkPlane > DisplayWorking Plaine 

Прорисовываем всё, что есть: U_M > Plot > Multi-Plots  

Возвращаемся к глобальной декартовой системе координат: 

U_M > WorkPlane > Change Active CS to > Global Cartesian 

 

 

 

7 

Размер стороны элемента для разбиения: 

ANSYS разбивает площадь сечения на плоские четырёхсторонние неисполняемые 

конечные элементы. Для каждого такого элемента отработаны формулы поиска 

площади, центра тяжести и т.д. Оперируя этими величинами, программа ищет 

геометрические характеристики всего сечения. 

M_M  > Preprocessor > Meshing > Size Cntrls > ManualSize > 
Global > Size 

Size пишем, например a 

> OK 

 

y 

x 
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№ Действие Результат 

8 

Разбиваем фигуру на элементы и сохраняем разбиение на диске: 

M_M  > Preprocessor > Sections > Beam > Custom Sections >  

> Write From Areas > 

Окно “Note” закройте 

Левой кнопкой мыши нажать на построенную фигуру 

> OK 

В появившемся окне “Write Section Library File” в поле FILE 

напишите имя файла типа “.SECT”, в котором будет храниться 

разбиение построенной фигуры, например S1 

> OK 
 

9 

Считываем разбиение с диска, как поперечное сечение №1: 

M_M  > Preprocessor > Sections > Beam > Custom Sections > 
> Read Sect Mesh > 

[SECTYPE] пишем 1 

Section Name пишем название сечения, например Triangle 

[SECREAD] пишем название сохранённого файла S1 

> OK 
 

10 

Прорисовываем сечение Rectangl: 

M_M > Preprocessor > Sections > Beam > Plot Section 

[Secplot] установить “1 Triangle” 

Show section mesh? установить “Yes” 

> OK 

Здесь геометрические характеристики сечения мы видим относительно 

горизонтальной и вертикальной центральной осей. 

 



8 

http://www.tychina.pro/библиотека-задач-1/ 

№ Действие Результат 

11 

Сдвиговую жёсткость поперечного сечения Triangle устанавливаем очень высокую 

для того, чтобы сдвиговые деформации не вносили вклад в перемещения: 

M_M  > Preprocessor > Sections > Beam > Sect Control> 
Section ID выбираем “1 Rectangl” 

TXZ пишем 1e6 

TXY пишем 1e6 

> OK 
 

12 

Сечение задано, поверхность, по которой оно задавалось удаляем; больше эта 

поверхность не понадобится: 

U_M > Plot > Area 

M_M > Preprocessor > Modeling > Delete > Area and Below > 

> Pick All 
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№ Действие Результат 

Балка, твердотельное моделирование 

13 

Ключевые точки С→1, D→2, и точка 3 в вертикальной плоскости для ориентации 

поперечного сечения: 

Активной устанавливаем систему координат №11 главных центральных осей: 

U_M > WorkPlane > Change Active CS to > Specified Coord Sys 

В окошке KCN пишем 11 

> OK 

 - изометрия;   - автоформат (меню справа). 

Точки, лежащие  на оси стержня проставляем в этой системе координат: 

M_M> Preprocessor> Mоdeling> Create> Keypoints> In Active CS> 

NPT пишем 1 

X,Y,Z пишем 0,0,0 > Apply > 

NPT пишем 2 

X,Y,Z пишем 0,0,l    > OK 

Прорисовываем всё, что есть: U_M > Plot > Multi-Plots 

Возвращаемся к глобальной декартовой системе координат: 

U_M > WorkPlane > Change Active CS to > Global Cartesian  

Копируем вверх по вертикали одну из точек оси (например точку №2): 

M_M > Modeling > Copy > Keypoints 

Кликаем на ключевую точку 2 

> OK > 

В окошке DY пишем величину вертикального смещения, 

 например l 
> OK 

Прорисовываем всё, что есть: U_M > Plot > Multi-Plots 
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№ Действие Результат 

14 

Один участок  – одна линия: 

M_M > Preprocessor > Mоdeling > Create > Lines > Lines > 

Straight Line > 

Левой кнопкой мыши последовательно нажать на ключевые точки: 

1 и 2 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 

 

15 

Заделка: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Displacement > On Keypoints > 

Левой кнопкой мыши нажать на 1 ключевую точку 

> OK > 

Lab2 установить “All DOF” 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

16 

Внешний сосредоточенный момент: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Force/Moment > On Keypoints > 

Левой кнопкой мыши кликнуть на 2 ключевую точку 

> OK > 

Lab установить “MX” 

VALUE установить “-M” 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots  

Конечноэлементная модель 

17 

Указываем материал, тип элементов и номер поперечного сечения: 

M_M > Preprocessor > Meshing > Mesh Attributes > All Lines > 

MAT установить “1” 

TYPE установить “1 BEAM188” 

SECT установить “1 Triangle” 

Pick Orientation Keypoint(s) установить “Yes” 

> OK > 

Кликаем мышкой на точку 3 

> OK 
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№ Действие Результат 

18 

Размер элементов: 

Два балочных конечных элемента на весь стержень: 

M_M > Preprocessor > Meshing > Size Cntrls > ManualSize > 

Lines > All Lines > 

NDIV пишем 2 

> OK 

Обновляем изображение: 

U_M > Plot > Multi-Plots 

При необходимости корректируйте масштаб:   или .  

19 

Скрываем оси глобальной декартовой системы координат: 

U_M> PlotCtrls> Window Controls> Window Options> 

[/Triad] установить “Not Shown” 

> OK 
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20 

Рабиваем линию на элементы: 

M_M > Preprocessor > Meshing > Mesh > Lines > Pick All 

Обновляем изображение: 

U_M > Plot > Multi-Plots 

 - автоформат. 

Видим сразу две модели – твердотельную и конечноэлементную. 

 

21 

Указываем, что именно нужно теперь прорисовывать по команде Multi-Plots: 

U_M > PlotCtrls > Multi-Plot Controls >  

Появляется первое окно Multi-Plotting > 

> OK > 

Появляется второе окно Multi-Plotting > 

Ставим отметки только напротив Nodes и Elements 

> OK 

Обновляем изображение: 

U_M > Plot > Multi-Plots 

 - переходим к такой изометрии, она удобнее; 

Теперь видим только конечноэлементную модель: чёрные точки с номерами – узлы 

модели (1, 2, 3, 4 и 5), цветные линии – балочные конечные элементы, рядом с их 

центрами тяжести видим номера этих элементов(1 и 2). 

В той же точке, что и узел 1 стоит система координат №11. Их номера сливаются. 
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№ Действие Результат 

22 

Переносим на конечноэлементную модель нагрузки и закрепления с модели 

твердотельной: 

M_M > Loads > Define Loads > Operate > Transfer to FE > All 

Solid Lds > OK 

 

 

Обновляем изображение: 

U_M > Plot > Multi-Plots 

 

 

Расчёт 

23 

Запускаем расчёт: 

M_M > Solution > Solve > Current LS 

Синхронно появляются два окна: белое информационное и серое исполнительное. 

Белое закрываем, на сером нажимаем OK. Расчёт пошёл. 

Когда он закончится, появится окно «Solution is done!». Закройте это окно. Расчёт 

окончен.   
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№ Действие Результат 

Просмотр результатов: 

24 

Форма упругой оси нагруженной балки: 

M_M > General Postproc > Plot Results > Deformed Shape > 

KUND установить Def + undeformed > OK 

Некоторые символы пропадают. Восстановим их: 

U_M > PlotCtrls > Symbols > 

Boundary condition устанавливаем “All Applied BCs” 

> OK 

Форма стержня до нагружения (недеформированная) изображена сеткой чёрным 

цветом, форма после нагружения (деформированная) изображена цветными 

линиями. Прогибается вверх и в сторону, всё правильно.  

25 

Выделяем элемент №2, узел №3: 

Элемент: 

U_M > Select > Entities… > 

В Select Entities установить “Elements” и “By Num/Pick” 

Селектор установить на «From Full» 

> OK > 

Мышкой кликнуть на элемент №2 (фиолетовый) 

> OK 

Узел: 

U_M > Select > Entities… > 

В Select Entities установить “Nodes” и “By Num/Pick” 

Селектор установить на «From Full» 

> OK > 

Мышкой кликнуть на узел №3 

> OK 

Рисуем что выделили: U_M > Plot > Multi-Plots 
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№ Действие Результат 

26 

Система координат №11 главных центральных осей устанавливается, как основная 

для построений и для распечатки результатов: 

Активной устанавливаем систему координат №11: 

U_M > WorkPlane > Change Active CS to > Specified Coord Sys 

В окошке KCN пишем 11 

> OK 

Результаты пропечатывать в системе координат №11: 

M_M > General Postproc > Options for Outp > 

[RSYS] Results for Output установить “Local system” 

В окошке Local system reference no. указать 11 

> OK 

 

27 

Усилия, с которыми выделенный элемент действует на выделенный узел: 

Узел, относительно которого будут вычисляться моменты: 
M_M > General Postproc > Nodal Calcs > Summation Pt > At Node 

Левой кнопкой мыши кликнуть на узел №3 

> OK 

Показать все шесть усилий (три силы, три момента): 
M_M > General Postproc > Nodal Calcs > Total Force Sum 

LAB установить “Active RSYS” 

ITEM установить “ALL” 

> OK 

Внутренние изгибающие моменты равны: 

X 0, 71M 70   ;  Y 0, 71M 70  . 

Точное совпадение с результатами аналитического расчёта (рис. 1). 

П р и м е ч а н и е: Иногда результаты получаются нулевые. Это сбой. 

Последовательно нажмите кнопки  и  и попробуйте ещё раз. 

  



17 

http://www.tychina.pro/библиотека-задач-1/ 

№ Действие Результат 

28 

Выделяем всё и прорисовываем конечные элементы: 

U_M > Select > Everything 

U_M > Plot > Elements 

Автоформат – кнопка   справа от рабочего поля. 

 

29 

Прорисовываем конечные элементы полноразмерно: 

U_M > PlotCtrls > Style > Size and Shape > 

[/ESHAPE] установить галочку “On” 

> OK 
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№ Действие Результат 

30 

Цветовая шкала будет состоять из десяти цветов: 

U_M > PlotCtrls > Style > Contours > Uniform Contours > 

NCONT пишем 10 > OK 

 

31 

Напряжения будем смотреть на недеформированной форме: 

U_M > PlotCtrls > Style > Displacement Scaling > 

DMULT устанавливаем “0.0(off)” 

> OK 

 

32 

Осевые напряжения в выделенном элементе: 

M_M > General Postproc > Plot Results > Contour Plot > 

Element Solu> Element Solution> Stress> X-Component of stress 

> OK 
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№ Действие Результат 

33 

Фронтальный вид: 

 - вид спереди;   - автоформат. 

Наиболее опасные точки поперечного сечения отмечены надписями MN и MX 

min B 2 ;4     

max A 2 .4    

Точное совпадение с результатами аналитического расчёта (рис. 1.). 

Местоположения точек A и B совпадают. 
 

34 

Настройка нелинейной цветовой шкалы: 

U_M > PlotCtrls > Style > Contours > Non-niform Contours… 

V1 пишем -1e6 

V2 пишем 0 

V3 пишем 1e6 

> OK 

Растянутая зона поперечного сечения окрасится в красный 

цвет, сжатая - в зелёный. Изменим палитру: голубой и жёлтый. 

U_M > PlotCtrls > Style > Colors > Contour Colors… >  

Contour Number 2 устанавливаем “голубой” 

Contour Number 3 устанавливаем “жёлтый” 

> OK 

Видим нейтральную линию (н.л.), отделяющую растянутые зоны друг от 

друга.Линия проходит через центр тяжести сечения (там прилоден вектор внешнего 

момента) и точку D сечения (рис. 1.). 
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Сохраняем проделанную работу: 

U_M > File > Save as Jobname.db 

Закройте ANSYS: 

U_M > File > Exit > Quit – No Save! > OK 

 

После выполнения указанных действий в рабочем каталоге остаются 

файлы с расширениями “.BCS”, “.db”, “.emat”, “.err”, “.esav”, “.full”, “.log”, 

“.mntr”,  “.rst”, ”.stat” и “SECT”. 

Интерес представляют “.db” (файлы модели), “.rst” (файл результатов 

расчёта) и файл “.SECT” (поперечное сечение), остальные файлы 

промежуточные, их можно удалить. 

 

 

 


