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F-08 (ANSYS) 

Формулировка задачи: 

Дано: Балка постоянной жёсткости с 

врезанным шарниром; шарнирная 

опора на левом краю, заделка на 

правом; нагружена силой q·l, 

распределённой нагрузкой q и 

моментом q·l
2
/8. 

E – модуль упругости материала; 

IZ – изгибный момент инерции. 

Построить: Эпюру внутренней перерезывающей силы QY;  

Эпюру внутреннего изгибающего момента MZ. 

Аналитический расчёт (см. F-08) даёт следующие решения: 
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Рис. 1. 

Задача данного примера: при помощи ANSYS Multyphisics получить эти же 

эпюры методом конечных элементов. 
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Предварительные настройки: 

Для решения задачи используется ANSYS Multiphysics 14.0: 

 

 

 

Utility Menu (U_M) 

Main Menu 

(M_M) 

Рабочее поле 

ANSYS Command Prompt (C_P) 

Кнопка 

Fit 

 

C меню M_M и U_M работают мышью, выбирая нужные опции. 

В окно C_P вручную вводят текстовые команды, после чего следует 

нажать на клавиатуре . 

Меняем чёрный цвет фона на белый следующими действиями: 

U_M > PlotCtrls > Style > Colors > Reverse Video 

Оставить в меню только пункты, относящиеся к прочностным расчётам: 

M_M > Preferences > Отметить “Structural” > OK 

Нумеровать точки и линии твердотельной модели: 

U_M > PlotCtrls > Numbering > 

Отметить KP, LINE ; 

Установить Elem на “No numbering”; 

Установить [/NUM] на “Colors & numbers” > OK 

Для большей наглядности увеличим размер шрифта: 

U_M > PlotCtrls > Font Controls > Legend Font > 

Установить «Размер» на «22» > OK 

U_M > PlotCtrls > Font Controls > Entity Font > 

Установить «Размер» на «22» > OK 

Предварительные настройки выполнены, можно приступать к решению задачи. 
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Решение задачи: 

Приравняв E, IZ, q и l к единице, результаты получим в виде чисел, обозначенных на рис. 1. синим цветом. 

№ Действие Результат 

1 

Задаём параметры расчёта – базовые величины задачи: 

U_M > Parameters > Scalar Parameters > 

E=1 > Accept > 

A=1e6 > Accept > 

Iz=1 > Accept > 

q=1 > Accept > 

l=1 > Accept > 

nu=0.3 > Accept > 

> Close  

2 

Первая строчка в таблице конечных элементов – плоский балочный тип BEAM3: 

M_M  > Preprocessor 

C_P  > ET,1,BEAM3 >  

Посмотрим таблицу конечных элементов: 

M_M > Preprocessor > Element Type > Add/Edit/Delete > Close 
 

3 

Первая строчка в таблице параметров («реальных констант») выбранного типа 

конечного элемента:площадь поперечного сечения = A;момент инерции = Iz; высота 

= l/100. 

C_P > R,1,A,Iz,L/100 >  

Посмотрим таблицу реальных констант: 

M_M > Preprocessor > Real Constants > Add/Edit/Delete > Close 
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№ Действие Результат 

4 

Свойства материала стержня – модуль упругости и коэффициент Пуассона: 

M_M > Preprocessor > Material Props > Material Models > 

Structural > Linear > Elastic > Isotropic > 

В окошке EX пишем “E”, в окошке PRXY пишем “nu” 

> OK 

Закрываем окно «Deine Material Model Behavior».  

Твердотельное моделирование 

5 

Ключевые точки – границы участков: A  1, B2, CLEFT3, CRIGHT4 и D5: 

M_M> Preprocessor> Mоdeling> Create> Keypoints> In Active CS> 

NPT пишем 1 

X,Y,Z пишем 0,0,0 > Apply > 

NPT пишем 2 

X,Y,Z пишем l,0,0 > Apply > 

NPT пишем 3 

X,Y,Z пишем 2*l,0,0 > Apply > 

NPT пишем 4 

X,Y,Z пишем 2*l,0,0 > Apply > 

NPT пишем 5 

X,Y,Z пишем 3*l,0,0 > OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 

Справа от рабочего поля нажимаем кнопку Fit . 
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№ Действие Результат 

6 

Три участка  –  три линии: 

M_M > Preprocessor > Mоdeling > Create > Lines > Lines > 

Straight Line > 

Левой кнопкой мыши последовательно нажать на ключевые точки: 

1 и 2 

2 и 3 (загорится окошко выбора точки: «3 или 4»?) 

 
> Apply > 

4 и 5 (загорится окошко выбора точки: «3 или 4»?) 

 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 

 

Сразу будет светиться номер «3», поэтому сразу нажимайте 

OK. 

Таким образом, становится понятно, что в качестве конечной 

выбрана точка 3. 

Нажмите кнопку «Prev», появится номер «4», тогда нажмите 

 OK. 

Таким образом, становится понятно, что в качестве начальной  

выбрана точка 4. 
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№ Действие Результат 

7 

Опоры: 

Левая (шарнир):  

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Displacement > On Keypoints > 

Левой кнопкой мыши нажать на 1 ключевую точку 

> OK > 

Lab2 установить “UY” 

> OK 

Правая (заделка): 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Displacement > On Keypoints > 

Левой кнопкой мыши нажать на 5 ключевую точку 

> OK > 

Lab2 установить “All DOF” 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 

 

8 

Сосредоточенная внешняя сила: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Force/Moment > On Keypoints > 

Левой кнопкой мыши нажать на 2 ключевую точку 

> OK > 

Lab установить “FY” 

VALUE установить “q*l” 

> OK 
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№ Действие Результат 

9 

Сосредоточенный внешний момент: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Force/Moment > On Keypoints > 

Левой кнопкой мыши нажать на 4 ключевую точку; загорится 

окошко выбора точки: «3 или 4»? Нажмите кнопку «Prev», 

появится номер «4», тогда нажмите OK. 

> OK > 

Lab установить “MZ” 

VALUE установить “q*l**2/8” 

> OK 

 

10 

Изометрия: 

До сих пор модели мы рассматривали, используя фронтальный вид («сбоку»). 

Вектор изгибающего момента при этом виден плохо, а его направление не 

определяется вовсе. Меняем угол зрения: справа от рабочего поля нажимаем 

кнопки 

 - изометрия; 

  - автоформат (размер изображения по размеру окна рабочего поля). 

 

Конечноэлементная модель 

11 

Указываем материал, реальные константы и тип элементов: 

M_M > Preprocessor > Meshing > Mesh Attributes > All Lines > 

MAT установить “1” 

REAL установить “1” 

TYPE установить “1 BEAM3” > OK 
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№ Действие Результат 

12 

Левый участок нагружен распределённой поперечной силой, его нужно разбить 

несколькими конечными элементами; участки без распределённых нагрузок можно 

бить одним конечным элементом: 

M_M > Preprocessor > Meshing > Size Cntrls > ManualSize > 

Lines > Picked Lines > 

Левой кнопкой мыши кликаем на линию L1 

> OK 

NDIV пишем 10 

> Apply > 

Левой кнопкой мыши последовательно кликаем на линии L2и L3 

> OK 

NDIV пишем 1 

> OK 

Обновляем изображение: 
U_M > Plot > Multi-Plots 

 

13 

Указываем, что именно нужно теперь прорисовывать по команде Multi-Plots: 

U_M > PlotCtrls > Multi-Plot Controls >  

Появляется первое окно Multi-Plotting > 

> OK > 

Появляется второе окно Multi-Plotting > 

Оставляем в нём отметки только напротив Nodes и Elements 

> OK 
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14 

Рабиваем линии на элементы: 

M_M > Preprocessor > Meshing > Mesh > Lines > Pick All 

Обновляем изображение: 

U_M > Plot > Multi-Plots 

Бирюзовым цветом изображены балочные элементы. Чёрные точки – 

это их узлы. 

 

15 

Переносим на конечноэлементную модель нагрузки и закрепления с модели 

твердотельной: 

M_M > Loads > Define Loads > Operate > Transfer to FE > All 

Solid Lds 

> OK 
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16 

Шарнир в точке C: 

В точке C балки установлен врезанный шарнир (рис. 1а). Моделируется он так: при 

разбиении твердотельной модели в ключевых точках 3 и 4 образовалось по одному  

узлу модели конечноэлементной, координаты этих узлов совпадают; свяжем 

совпадающие узлы по двум поступательным степеням свободы UX и UY, по 

угловому перемещению узлы останутся развязаны. 

M_M > Preprocessor > Coupling/Ceqn > Coincident Nodes > 

Lab установить «UX» 

> OK > 

M_M > Preprocessor > Coupling/Ceqn > Coincident Nodes > 

Lab установить «UY» 

> OK 

 

17 

Поперечная распределённая нагрузка q: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Pressure > On Beams > 

Левой кнопкой мыши отмечаем 10 элементов левого участка 

> Apply > 

LKEY пишем 1 

VALI пишем q 

> OK 

 

Расчёт 

18 

Запускаем расчёт: 

M_M > Solution > Solve > Current LS 

Когда он закончится, появится окно «Solution is done!». Закройте это окно.  
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Просмотр результатов 

19 

Скрываем оси системы координат: 

U_M > PlotCtrls > Window Controls > Window Options > 

[/Triad] установить “Not Shown” 

> OK 
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20 

Силовая схема: 

U_M > PlotCtrls > Symbols > 

[/PBC] устанавливаем в положение “For Individual” 

Убираем галочку с “Miscellaneous” 

Surface Load Symbols устанавливаем Pressures 

Show pres and convect as  устанавливаем  Arrows 

> OK > 

В окне “Applied Boundary Conditions” 

  U установить “Off” 

Rot установить “Off” 

  F установить “Symbol+Value” 

  M установить “Symbol+Value” 

> OK >  

В окне “Reactions”  

NFOR установить “Off” 

NMOM установить “Off” 

RFOR установить “Symbol+Value” 

RMOM установить “Symbol+Value” 

> OK 

Обновляем изображение: U_M > Plot > Elements 

Получаем тот же результат, что и на рис. 1а .(числа, выделенные синим цветом). 

В рабочем поле видим следующее: 

- Красным цветом начерчены внешняя сила и распределённая нагрузка; 

- Синим цветом начерчен вектор внешнего момента; 

- Малиновым цветом нарисованы реактивные силы; 

- Фиолетовым цветом изображён вектор реактивного момента. 

 

21 

Цветовая шкала будет состоять из десяти цветов: 

U_M > PlotCtrls > Style > Contours > Uniform Contours > 

NCONT пишем 10 > OK 
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№ Действие Результат 

22 

Фронтальный вид: 

 - вид спереди; 

  - автоформат (размер изображения по размеру окна рабочего поля).  

23 

Составление эпюры внутренней перерезывающей силы: 

M_M > General Postproc > Element Table > Define Table > Add >  

“By sequence num”, “SMISC,”, “2” > Apply >  

“By sequence num”, “SMISC,”, “8” > OK > 

> OK > Close 

 

24 

Инвертирование эпюры внутренней перерезывающей силы: 

Строчку SMISC2 умножаем на -1, получаем строчку QYI: 

M_M > General Postproc > Element Table > Multiply 

LabR пишем QYI 

FACT1 пишем -1 

Lab1 устанавливаем SMIS2 

Lab2 устанавливаем –none- 

> Apply 

Строчку SMISC8 умножаем на -1, получаем строчку QYJ: 

M_M > General Postproc > Element Table > Multiply 

LabR пишем QYJ 

FACT1 пишем -1 

Lab1 устанавливаем SMIS8 

Lab2 устанавливаем –none- 

> OK 

Смотрим таблицу результатов: 

M_M > General Postproc > Element Table > Define Table > Close 
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№ Действие Результат 

25 

Прорисовка  эпюры внутренней перерезывающей силы: 

M_M > General Postproc > Plot Results > Contour Plot 

> Line Elem Res >  

Установить LabI в положение “QYI” 

Установить LabJ в положение “QYJ” 

> OK 

Получаем тот же результат, что и на рис. 1б (только числа, выделенные синим 

цветом). 

Можете рисунок эпюры сделать крупнее: коэффициент Fact установите 2 или 3.  

26 

Для того, чтобы лучше понимать, каким точкам стержня какое значение эпюры 

соответствует, повторите действие №20. Увидите, совмещённые с эпюрой 

внешние силы (кроме распределённых, увы) и реакции. 

 

27 

Составление эпюры внутреннего изгибающего момента: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “SMISC,”, “6” > Apply >  

“By sequence num”, “SMISC,”, “12” > OK > 

> Close 

Смотрим таблицу результатов: 

M_M > General Postproc > Element Table > Define Table > Close 
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28 

Прорисовка эпюры внутреннего изгибающего момента: 

M_M > General Postproc > Plot Results > Contour Plot 

> Line Elem Res > 

LabI установить “SMIS6” 

LabJ установить “SMIS12” 

Fact пишем 1 

> OK  

Получаем тот же результат, что и на рис. 1в. (только числа, выделенные синим 

цветом). Значения показывает цветовая шкала. 

Можете рисунок эпюры сделать крупнее: коэффициент Fact установите 2 или 3. 
 

29 

Величина экстремума параболы: 

U_M > Select > Entities… > 

В окошке Select Entities установить в окошках 

“Elements” 

“By Num/Pick” 

Точку селектора установить на «From Full» 

> OK > 

Левой кнопкой мыши кликнуть на элемент, визуально содержащий 

вершину (третий слева) 

> OK 

Перерисовываем эпюру. Теперь на одном только этом элементе: 

U_M > Plot > Replot 

Эпюра на элементе прямоугольна, и в левом и в правом узле выделенного элемента 

её значение равно 0,03. На рис. 1в. Экстремум указан точно 0,03125. Погрешность 

составляет 4%.  

Погрешность будет тем меньше, чем меньше размер элемента (то есть, чем на 

большее количество элементов разбит участок). 
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30 

Координата экстремума параболы: 

Номера узлов выделенного элемента – 4 и 5: 

U_M > List > Elements > Nodes+Attributes 

Координаты четвёртого и пятого узлов – x4=0,2; x5=0,3 : 

U_M > List > Nodes > OK 

Если значения момента в этих узлах одинаковы (по 0,03·q·l
2
), значит экстремум 

находится строго между ними и его координата: 

4 5x x 0,2 0,3 1
x* 0,25 l

2 2 4

 
      

…что в точности соответствует значению x
*
  на рис. 1. 

 

Снова прорисовываем полностью эпюру внутреннего изгибающего момента: 

U_M > Select > Everything 

U_M > Plot > Multi-Plots 
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Сохраняем проделанную работу: 

U_M > File > Save as Jobname.db 

Закройте ANSYS: 

U_M > File > Exit > Quit – No Save! > OK 

 

После выполнения указанных действий в рабочем каталоге остаются 

файлы с расширениями “.BCS”, “.db”, “.emat”, “.err”, “.esav”, “.full”, “.log”, 

“.mntr”,  “.rst” и ”.stat”. 

Интерес представляют “.db” (файл модели) и “.rst” (файл результатов 

расчёта), остальные файлы промежуточные, их можно удалить. 

 


