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A-05 (ANSYS) 

Формулировка задачи: 

Дано: Консольный стержень нагружен 

распределённой осевой  силой q. 

E – модуль упругости материала; 

A – площадь поперечного сечения. 

Найти: эпюра N – внутренняя осевая растягивающая сила; эпюра σ – осевое 

напряжение; эпюра ε – осевая деформация; эпюра w – осевое перемещение 

сечений; потенциальная энергия упругого деформирования U. 

Аналитический расчёт (см. A-05) даёт следующие решения: 
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Рис. 1. 

Задача данного примера: при помощи ANSYS Multyphisics получить эти же 

решения методом конечных элементов. 
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http://www.tychina.pro/app/download/7945554493/A-05.pdf
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Предварительные настройки: 

Для решения задачи используется ANSYS Multiphysics 14.0: 

 

 

 

Utility Menu (U_M) 

Main Menu 

(M_M) 

Рабочее поле 

ANSYS Command Prompt (C_P) 

Кнопка 

Fit 

 

C меню M_M и U_M работают мышью, выбирая нужные опции. 

В окно C_P вручную вводят текстовые команды, после чего следует 

нажать на клавиатуре . 

Меняем чёрный цвет фона на белый: 

U_M > PlotCtrls > Style > Colors > Reverse Video 

Убрать пункты меню, не относящиеся к прочностным расчётам: 

M_M > Preferences > Отметить “Structural” > OK 

Нумеровать точки и линии твердотельной модели, узлы и элементы 

модели конечноэлементной: 

U_M > PlotCtrls > Numbering > 

Отметить KP, LINE, NODE, установить Elem на “No numbering”, 

установить [/NUM] на “Colors & numbers” > OK 

Увеличить размер шрифта: 

U_M > PlotCtrls > Font Controls > Legend Font > 

Установить «Размер» на «22» > OK 

U_M > PlotCtrls > Font Controls > Entity Font > 

Установить «Размер» на «22» > OK 

Предварительные настройки выполнены, можно приступать к решению задачи. 
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Решение задачи: 

Приравняв E, A, q и l, к единице, результаты получим в виде чисел, обозначенных на рис. 1. синим цветом.  

№ Действие Результат 

1 

Задаём параметры расчёта – базовые величины задачи: 

U_M > Parameters > Scalar Parameters > 

E=1 > Accept > 

A=1 > Accept > 

Iz=1e6 > Accept > 

q=1 > Accept > 

l=1 > Accept > 

nu=0.3 > Accept > Close  

Iz – изгибный момент инерции поперечного сечения; 

nu – коэффициент Пуассона для металлов.  

2 

Первая строчка в таблице конечных элементов – плоский балочный тип BEAM3: 

M_M  > Preprocessor 

C_P  > ET,1,BEAM3 >  

 

3 

Первая строчка в таблице реальных констант: площадь  A; момент инерции  Iz; 

высота l/10. 

C_P > R,1,A,Iz,L/10 >  

 

4 

Свойства материала стержня – модуль упругости и коэффициент Пуассона: 

M_M > Preprocessor > Material Props > Material Models > 

Structural > Linear > Elastic > Isotropic > 

EX пишем “E”, 

PRXY пишем “nu” 

> OK > Закрываем окно«Deine Material Model Behavior». 
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№ Действие Результат 

Твердотельное моделирование 

5 

Ключевые точки – границы участков (две точки): 

M_M > Preprocessor > Mоdeling > Create > Keypoints > In 

Active CS > 

NPT пишем 1 

X,Y,Z пишем 0,0,0 

> Apply > 

NPT пишем 2 

X,Y,Z пишем l,0,0 

 > OK 

Прорисовываем всё, что есть:  U_M > Plot > Multi-Plots 

Справа от рабочего поля нажимаем кнопку Fit . 

 

6 

Один участок –  одна линия между точками: 

M_M > Preprocessor > Mоdeling > Create > Lines > Lines > 

Straight Line > 

Левой кнопкой мыши нажать последовательно на 1 ключевую 

точку, потом на 2 

> OK 

 

7 

Заделка: 

M_M > Preprocessor > Loads > Define Loads > Apply > Structural 

> Displacement > On Keypoints > 

Левой кнопкой мыши нажать на 1 ключевую точку > OK > 

Lab2 установить “All DOF” > OK 
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№ Действие Результат 

Конечноэлементная модель 

8 

Указываем материал, реальные константы и тип элементов, на которые будут 

разбиты линии твердотельной модели: 

M_M > Preprocessor > Meshing > Mesh Attributes > Picked Lines 

> Левой кнопкой мыши нажать на линию L1 > OK > 

MAT установить “1” 

REAL установить “1” 

TYPE установить “1 BEAM3” 

> OK 

 

9 

Участок c распределённой нагрузкой нужно бить несколькими конечными 

элементами (чем их больше, тем выше точность и меньше наглядность): 

M_M > Preprocessor > Meshing > Size Cntrls > ManualSize > 

Lines > Picked Lines> 

Левой кнопкой мыши нажать на линию L1 

> OK >  

NDIV пишем 10 

> OK 

Обновляем изображение: U_M > Plot > Multi-Plots 

 

10 

Рабиваем линию на элементы (в данном случае, десять элементов): 

M_M > Preprocessor > Meshing > Mesh > Lines > 

Левой кнопкой мыши нажать на линию L1 

> OK >  

Обновляем изображение: 

U_M > Plot > Elements 

 

 

номера узлов 
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№ Действие Результат 

11 

Переносим на конечноэлементную модель закрепления с модели твердотельной: 

M_M > Preprocessor > Loads > Define Loads > Operate > 

> Transfer to FE > All Solid Lds > OK  

12 

Распределённую осевую нагрузку q прикладываем непосредственно к балочным 

элементам. Элементы ориентированы потвердотельной линии L1, а линия – от т.1 

до т.2, то есть, слева направо. Значит, распределённая нагрузка, направленная 

справа налево должна быть отрицательна: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Pressure > On Beams >  

Левой кнопкой мыши последовательно нажать из каждый из 10 

балочных элементов > OK > 

LKEY пишем 2 

VALI пишем -q 

VALJ пишем –q 

> OK 

Окно “Both solid model and finite element…” просто закройте, если появится.  

Расчёт 

13 

Запускаем расчёт: 

M_M > Solution > Solve > Current LS 

Синхронно появляются два окна: белое информационное и серое исполнительное. 

Белое закрываем, на сером нажимаем OK. 

Расчёт пошёл. 

Когда он закончится, появится окно «Solution is done!». Закройте это окно. 

Расчёт окончен. 
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Просмотр результатов 

14 

Скрываем оси системы координат: 

U_M > PlotCtrls > Window Controls > Window Options > 

[/Triad] установить “Not Shown” 

> OK 

 

15 

Силовая схема: 

U_M > PlotCtrls > Symbols > 

[/PBC] устанавливаем в положение “For Individual” 

Убираем галочку с “Miscellaneous” 

[/PSF] устанавливаем в положение “Pressures” 

> OK >  

В окне “Applied Boundary Conditions”  U установить “Off” 

                           Rot установить “Off” 

                             F установить “Symbol+Value” 

                             M установить “Symbol+Value” 

> OK >  

В окне “Reactions”    NFOR установить “Off” 

               NMOM установить “Off” 

               RFOR установить “Symbol+Value” 

               RMOM установить “Symbol+Value” 

> OK >  

Обновляем изображение:  U_M > Plot > Elements 

Получаем тот же результат, что и на рис. 1а. 

Зелёным цветом указана внешняя распределённая сила q, малиновым цветом – 

реакция.  
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№ Действие Результат 

16 

Цветовая шкала будет состоять из десяти цветов: 

U_M > PlotCtrls > Style > Contours > Uniform Contours > 

NCONT пишем 10 

> OK 

 

17 

Составление эпюры внутренней растягивающей осевой силы: 

M_M > General Postproc > Element Table > Define Table > Add >  

“By sequence num”, “SMISC,”, “1” > Apply >  

“By sequence num”, “SMISC,”, “7” > OK > Close 

 

18 

Прорисовка  эпюры внутренней растягивающей осевой силы: 

M_M > General Postproc > Plot Results > Contour Plot 

> Line Elem Res >  

LabI установить “SMIS1” 

LabJ установить “SMIS7” 

> OK  

Получаем тот же результат, что и на рис. 1б.  

Точно нуль у ANSYS не получился, получилось очень малое число 0,333·10
-15

. 

Видим эпюру, высота каждого столбика которой можно определить по его цвету. 

Цифры 1…11 есть номера узлов конечноэлементной модели (см. действие №10).   
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№ Действие Результат 

19 

Составление эпюры осевого напряжения: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “LS,”, “1” > Apply >  

“By sequence num”, “LS,”, “4” > OK > Close 

 

20 

Прорисовка эпюры осевого напряжения: 

M_M > General Postproc > Plot Results > Contour Plot 

> Line Elem Res > 

LabI установить “LS1” 

LabJ установить “LS4” 

> OK  

Получаем тот же результат, что и на рис. 1в. (только числа, выделенные на рис. 1в. 

синим цветом). Эпюра MIN=-1 , MAX≈0. 

 

21 

Составление эпюры линейной осевой деформации: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “LEPEL,”, “1” > Apply >  

“By sequence num”, “LEPEL,”, “4” > OK > Close  

 

22 

Прорисовка эпюры линейной осевой деформации: 

M_M > General Postproc > Plot Results > Contour Plot 

> Line Elem Res > 

LabI установить “LEPE1” 

LabJ установить “LEPE4” 

> OK  

Получаем тот же результат, что и на рис. 1г. (только числа, выделенные на рис. 1г. 

синим цветом). Эпюра MIN=-1 , MAX≈0.. 
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№ Действие Результат 

 

Осевые перемещения (рис.1д.) в можно получить только дискретно, в узлах модели. Просмотреть результат можно тремя способами: 

а) Цветовая диаграмма (между узлами решение линейно интерполируется); 

б) Таблица перемещений в узлах; 

в) Дискретная эпюра (перемещение по всей длине элемента осредняется); 

г) Эпюра (линейная интерполяция). 

Последнее – наиболее наглядно, но и наиболее трудоёмко. Просмотрим перемещения всеми тремя способами. 

23 

Осевые перемещения сечений стержня (цветовая шкала): 

M_M > General Postproc > Plot Results > Contour Plot > Nodal 

Solu > Nodal Solution > DOF Solution > X-Component of 

displacement > OK 

Цифры 1…11 есть номера узлов конечноэлементной модели (см. действие №10). 

 

24 

Осевые перемещения сечений стержня (таблица): 

M_M > General Postproc > List Results > Nodal Solution > 

Nodal Solution > DOF Solution > X-Component of displacement 

> OK 

Получаем окно “PRNSOL Command” с табличкой, где NODE – номер узла 

конечноэлементной модели, а UX – его перемещение по горизонтали (“+” – по оси X, 

“-” - против). Для того, чтобы вспомнить, где какой узел, выбираем: 

U_M > Plot > Nodes 
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№ Действие Результат 

25 

Вычисление дискретной эпюры осевых перемещений: 

M_M > General Postproc > Element Table > Define Table > Add >  

В левом списке выбрать “DOF solution” 

потом 

в правом верхнем списке выбрать “Translation UX” 

> OK > Close 
 

26 

Прорисовка дискретной эпюры осевых перемещений: 

M_M > General Postproc > Plot Results > Contour Plot 

> Line Elem Res > 

LabI установить “UX” 

LabJ установить “UX” 

> OK  

 

В рабочем поле появляется столбчатая диаграмма, аппроксимирующая эпюру 

осевых перемещений рис. 1д. Ширина столбика соответствует длине элемента, на 

котором он рисуется, высота указывается цветом (внизу рабочего поля приведена 

цветовая шкала), соответствует алгебраическому среднему перемещений w 

начального и конечного узлов элемента. Это легко проверить по таблице из 

действия 24. 

Чем больше будет количество элементов, на которые разбит рассматриваемый 

участок стержня, тем ближе эпюра, которую мы видим в рабочем поле, будет к 

эпюре рис. 1д.  
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№ Действие Результат 

27 

Осевые перемещения сечений стержня (подготовка эпюры): 

Создаём массив-таблицу с названием, например, wtable : 

U_M > Parameters > Array Parameters > Define/Edit > Add >  

Par=”wtable” 

Type=”Table” 

I,J,K = 11,2,1 

> OK > Edit > 

Нумеруем столбец и строки массива. 

Заполняем массив вручную. Первый столбец – координаты узлов по возрастанию, то 

есть координаты узлов 1, 3, 4, 5, 6, 7, 8, 9, 10, 11, 2. Расстояния между соседними 

узлами по l/10 то есть по 0,1. Второй столбец - перемещения UX узлов (см. действие 

№24). 

Все 11 строк на одной странице не умещаются. Пользуйтесь кнопками для 

перелистывания в верхнем правом углу окна. 

> File > Apply/Quit > Close 
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№ Действие Результат 

28 

Осевые перемещения сечений стержня (прорисовка эпюры): 

Параметры, необходимые для построения эпюры: по горизонтальной оси будет 

откладываться первый столбец массива, по оси ординат – второй столбец массива. 

U_M > Parameters > Scalar Parameters… > 

XN=1 > Accept > YN=2 > Accept > Close 

Сетка будет на обеих осях эпюры: 

U_M > PlotCtrls > Style > Graphs > Modify Grid > 

[/GRID] установить “X and Y lines”  

> OK 

Горизонтальную ось подписываем “L”, вертикальную ось подписываем “w”, 

интервал по горизонтальной оси устанавливаем от левого конца стержня до правого 

(0…L), а интервал по вертикальной оси таким, чтобы поместилась эпюра (-0,5…0): 

U_M > PlotCtrls > Style > Graphs > Modify Axes > 

 [/AXLAB] X-axis label пишем L  

 [/AXLAB] Y-axis label пишем w  

[/XRANGE] установить “Specified range”  

XMIN,XMAX установить “0” и “1” 

 [/YRANGE] установить “Specified range”  

YMIN,YMAX установить “-0.5” и “0” 

> OK 

Прорисовываем эпюру: 

U_M > Plot > Array Parameters  

ParX установить “wtable(1,XN)”  

ParY установить “wtable(1,YN)”  

> OK 

 



14 

http://www.tychina.pro 

№ Действие Результат 

29 

Потенциальная энергия упругой деформации U: 

M_M > General Postproc > List Results > Element Solution > 

Energy > Strain energy > OK 

Получаем список «Элемент-энергия». Суммируем энергию: 

 
2 3

U 0,045125 0,036125 0,028125 0,021125 0,015125 0,010125

0,006125 0,003125 0,001125 0,000125

1
0,16625

6,015

q l
Äæ

E A
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 





  


   

Получаем тот же результат, что и на рис. 1е. (только коэффициент перед формулой, 

выделенный на рис. 1е. синим цветом). 
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Сохраняем проделанную работу: 

U_M > File > Save as Jobname.db 

Закройте ANSYS: 

U_M > File > Exit > Quit – No Save! > OK 

 

После выполнения указанных действий в рабочем каталоге остаются файлы с 

расширениями “.BCS”, “.db”, “.emat”, “.err”, “.esav”, “.full”, “.log”, “.mntr”,  “.rst” и 

”.stat”. 

Интерес представляют “.db” (файл модели) и “.rst” (файл результатов расчёта), 

остальные файлы промежуточные, их можно удалить. 

 

 

 

 

 


