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I-07 (ANSYS) 
Формулировка задачи: 

Дано: Консольный стержень внецентренно нагружен двумя осевыми силами. 

E – модуль упругости материала/ 

Найти: 

1) Главные осевые моменты инерции 

поперечного сечения IX и IY ; 

2) Внутренние изгибающие моменты 

MX  и MY  в сечениях бруса; 

3) Эпюру распределения нормальных 

напряжений σ в сечениях бруса. 

Аналитический расчёт (см. I-07) даёт следующие решения: 
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Задача данного примера: при помощи ANSYS Multyphisics получить эти же 

результаты методом конечных элементов. 
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Рис. 1. 

http://www.tychina.pro/app/download/7960966793/I-07.pdf
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Предварительные настройки: 

Для решения задачи используется ANSYS Multiphysics 14.0: 

 

 

 

Utility Menu (U_M) 

Main Menu 

(M_M) 

Рабочее поле 

ANSYS Command Prompt (C_P) 

Кнопка 

Fit 

 

C меню M_M и U_M работают мышью, выбирая нужные опции. 

В окно C_P вручную вводят текстовые команды, потом . 

Меняем чёрный цвет фона на белый следующими действиями: 

U_M > PlotCtrls > Style > Colors > Reverse Video 

Оставить в меню пункты, относящиеся только к прочностным расчётам: 

M_M > Preferences > Отметить “Structural” > OK 

Нумеровать ключевые точки, линии, поверхности твердотельной модели: 

U_M > PlotCtrls > Numbering > 

Отметить KP, LINE, AREA 

> OK 

Будем работать с локальными системами координат. Прорисовывать их: 

U_M > PlotCtrls > Symbols > 

CS устанавливаем в положение“on” 

> OK 

Для большей наглядности увеличим размер шрифта: 

U_M > PlotCtrls > Font Controls > Legend Font > 

«Размер» на «22» 

> OK 

U_M > PlotCtrls > Font Controls > Entity Font > 

«Размер» на «22» 

> OK 

Предварительные настройки выполнены, можно приступать к решению задачи.
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Решение задачи: 

Приравняв  F  и  a  к единице, результаты получим в виде чисел, обозначенных на рис. 1. синим цветом. 

Длина стержня l на результат не влияет; из эстетических соображений зададим её, как 20a. Задача статически определима, 

то есть, модуль упругости первого рода  E  материала стержня на результат так же не влияет; зададим его единицей, а 

коэффициент Пуассона  ν  во избежание наличия поперечных деформаций приравняем к нулю (как у пробки). 

Для создания плоского поперечного сечения понадобятся элементы из жёсткого материала. Для него модуль упругости 

первого рода  Erigid  выберем на несколько порядков больше, чем  E. 

№ Действие Результат 

1 

Задаём параметры расчёта – базовые величины задачи: 

U_M > Parameters > Scalar Parameters > 

F=1        > Accept > 

a=1        > Accept > 

l=20*a     > Accept > 

E=1        > Accept > 

Erigid=1e5 > Accept > 

nu=0       > Accept > 

> Close 
 



4 

http://www.tychina.pro/библиотека-задач-1/ 

№ Действие Результат 

2 

Таблица конечных элементов – объёмный и плоский неисполняемый: 

M_M > Preprocessor > Element Type > Add/Edit/Delete > Add 

Element reference number пишем 1 

В левом окошке выбираем “Solid” 

В правом окошке “20node 186” 

> Apply > 

Element reference number пишем 2 

В левом окошке выбираем “Not Solved” 

В правом окошке Mesh Facet 200” 

> OK > 

В окошке Element types отметить строчку “3 MESH200” 

> Options > 

K1 установить “QUAD 8-NODE” 

> OK > 

> Close 

 

3 

Таблица материалов: (№1 – податливый материал; №2 – жёсткий материал) 

M_M > Preprocessor > Material Props > Material Models > 

Structural > Linear > Elastic > Isotropic > 

EX пишем E 

PRXY пишем nu 

> OK > 

> Material > New Model… 

Define Material ID пишем 2 

> OK > 

Structural > Linear > Elastic > Isotropic > 

EX пишем Erigid 

PRXY пишем nu 

> OK 

Закрываем окно «Deine Material Model Behavior». 
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№ Действие Результат 

Поперечное сечение 

4 

Координаты точек поперечного сечения: 

Построить поверхность, размерами и формой повторяющюю заданное 

поперечное сечение, можно различными способами. Проще всего построить два 

прямоугольника и произвести логическую операцию их наложения, чтобы 

поверхности не располагались в несколько слоёв. 

Для того, чтобы построить прямоугольник нужно знать координаты двух его 

противоположных углов в декартовой системе координат XYZ. 

Как именно по отношению к началу координат будет располагаться 

поверхность, не важно. Например, так, как показано на рис.1. Тогда координаты 

углов прямоугольников будут следующими: 
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№ Действие Результат 

5 

Поверхности поперечного сечения: 

Прямоугольники: 

M_M  > Preprocessor > Modeling > Create > Areas > Rectangle > 
By Dimensions 

X1, X2 пишем в окошках -a и a 

Y1, Y2 пишем в окошках 0 и 8*a 

> Apply > 

X1, X2 пишем в окошках -3*a и 3*a 

Y1, Y2 пишем в окошках 2*a и 0 

> OK 

 - автоформат (меню справа). 

К поверхностям применяется логическая операция наложения: 

M_M  > Preprocessor > Modeling > Operate > Booleans > 

> Overlap > Areas > Pick All  

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots  

Накладывающиеся части нескольких поверхностей становятся одной поверхностью; 

соприкасающиеся поверхности склеиваются. 
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№ Действие Результат 

6 

Геометрические характеристики начерченной поверхности: 

M_M > Preprocessor > Modeling > Operate > Calc Geom Items > 

Of Areas > 

Переключатель Selection устанавливаем как “Normal” 

> OK 

Получаем:
C C Cx 0 ; y 3 ; z 0    - координаты центра тяжести; 

THXY 0 ;THYZ 0 ;THZX 0   - углы перехода от глобальной декартовой 

системы координат к системе координат главных центральных осей; 

Для того, чтобы увидеть главные центральные оси, позиционируем по ним систему 

координат рабочей плоскости: 

U_M  > WorkPlane > Display Working Plain 

U_M  > WorkPlane > Offset WP by Increments > 

В окошке “X,Y,Z Offsets” пишем координаты центра 0,3,0 

В окошке “XY,YZ,ZX Angles” пишем угол перехода 0,0,0 

> OK 

Видим: положение центра тяжести фигуры и направления 

её главных центральных осей совпадают с указанными на рис.1. 

Главные моменты инерции фигуры: 

11xI IX 3X 1 6   

11yI I 4YY 0   

Эти результаты совпадают с приведенными на рис.1. (числа, 

выделенные синим цветом). 

  

  

y11 

x11 

11yI  

11xI  
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№ Действие Результат 

7 

Главные центральные оси поперечных сечений (система координат №11): 

Декартову систему координат №11 (главные центральные оси поперечных сечений 

стержня) создаём по системе координат рабочей плоскости: 

U_M > WorkPlane> Local Coordinate Systems> 

> Create Local CS> At WP Origin>  

KCN пишем 11 

KCS устанавливаем Cartesian (декартова) 

> OK 

Гасим оси координат рабочей плоскости: 

U_M > WorkPlane > DisplayWorking Plaine 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots  

 

 

Балка, твердотельное моделирование совмещается с одновременным созданием конечноэлементной модели 

8 

Размер стороны элемента для разбиения: 

M_M  > Preprocessor > Meshing > Size Cntrls > ManualSize > 
Global > Size 

Size пишем, например a 

> OK  

9 

Указываем материал, тип элементов и номер поперечного сечения: 

M_M > Preprocessor > Meshing > Mesh Attributes > All Areas > 

MAT установить “1” 

TYPE установить “2 MESH200” 

> OK 
 

y11 

x11 



9 

http://www.tychina.pro/библиотека-задач-1/ 

№ Действие Результат 

10 

Разбиваем фигуру на плоские неисполняемые элементы: 

M_M  > Preprocessor > Meshing > Mesh > Areas > Mapped > 

> 3 or 4 sided > Pick All 

> OK 

Прорисовываем всё, что есть: 
U_M > Plot > Multi-Plots 

 

11 

Изометрия: 

 - изометрия;   - автоформат (меню справа). 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 

 

12 

Закрепления: 

Узлы, лежащие в заделке, уже созданы; закрепляем по всем степеням свободы: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Displacement > On Nodes > Pick All 

Lab2 установить “All DOF” 

> OK 

Прорисовываем всё, что есть: U_M > Plot > Multi-Plots 

Предупреждающее окно “Warning” (если будет) закройте Close.  
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№ Действие Результат 

13 

Параметры выдавливания поверхности с плоской сеткой конечных элементов в 

объём с сеткой объёмных конечных элементов: 

M_M> Preprocessor> Modeling> Operate> Extrude> Elem Ext Opts> 

[TYPE] установить “1 SOLID186” 

[MAT]  установить “1” 

[VAL1] установить “2” 

[VAL2] установить “1/50” 

ACLEAR установить “Yes” 

> OK 

Это значит: выдавливаемые элементы будут типа №1 (таблица элементов) из 

материала №1 (таблица материалов), на всю длину балки их будет 2, причём вторые 

в 50 раз короче первых, после выдавливания поверхности почистить от 

неисполняемых конечных элементов.  

14 

Выдавливаем поперечное сечение в прямую балку: 

M_M > Preprocessor > Modeling > Operate> Extrude > Areas > 

> By XYZ Offset > Pick All 

Окошки DX,DY,DZ заполняем, как 0 0 l 

> OK 

Обновляем изображение: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

15 

Указываем, что именно нужно теперь прорисовывать по команде Multi-Plots: 

U_M > PlotCtrls > Multi-Plot Controls >  

Появляется первое окно Multi-Plotting > 

> OK > 

Появляется второе окно Multi-Plotting > 

Ставим отметки только напротив Nodes и Elements 

> OK 

Обновляем изображение: 

U_M > Plot > Multi-Plots 

Теперь видим только конечноэлементную модель: чёрные точки  – узлы модели, 

голубые брусочки – объёмные конечные элементы.  

16 

Элементы нумеровать только цветом по номеру материала: 

U_M > PlotCtrls > Numbering > 

Отметить KP, LINE, AREA 

[/NUM] устанавливаем “Colors only” 

> OK 
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№ Действие Результат 

17 

Создаём на конце стержня жёсткое плоское сечение: 

Выделяем узлы торца: 

U_M > Select > Entities… > 

В Select Entities установить “Nodes” и “By Location” 

Верхний селектор установить на “Z coordinates” 

В окошке Min,Max пишем l 

Нижний селектор установить на “From Full” 

> OK 

Прорисовываем выделенные узлы: 

U_M > Plot > Nodes 

Элементы, которые касаются выделенных узлов: 

U_M > Select > Entities… > 

В Select Entities установить “Nodes” и “Attached to” 

Верхний селектор установить на “Nodes” 

Нижний селектор установить на “From Full” 

> OK 

Прорисовываем выделенные узлы и элементы: 

U_M > Plot > Multi-Plots 

Меняем выделенным элементам материал с №1 (податливый) на №2 (жёсткий): 

M_M > Preprocessor > Modeling > Move/Modify > Elements > 

> Modify Attrib > Pick All > 

STLOC установить “Material MAT” 

В окошке I1 пишем 2 

> OK 

Обновляем изображение: 

U_M > Plot > Replot 
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№ Действие Результат 

18 

Рассматриваем, что получилось – податливая балка с жёским поперечным 

сечением на торце: 

U_M > Select > Everything 

U_M > Plot > Multi-Plots 

Автоформат – . 

 

19 

Внешние сосредоточенные силы: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Force/Moment > On Nodes > 

Левой кнопкой мыши кликнуть на узел в точке A (рис.1.) 

> OK > 

Lab установить “FZ” 

VALUE установить “4*F” 

> Apply > 

Левой кнопкой мыши кликнуть на узел в точке B (рис.1.) 

> OK > 

Lab установить “FZ” 

VALUE установить “-2*F” 

> OK 

Прорисовываем всё, что есть: U_M > Plot > Multi-Plots 
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№ Действие Результат 

Расчёт 

20 

Запускаем расчёт: 

M_M > Solution > Solve > Current LS 

Синхронно появляются два окна: белое информационное и серое исполнительное. 

Белое закрываем, на сером нажимаем OK. Расчёт пошёл. 

Когда он закончится, появится окно «Solution is done!». Закройте это окно. Расчёт 

окончен. 
  

 

Просмотр результатов: 

21 

Форма упругой оси нагруженной балки: 

M_M > General Postproc > Plot Results > Deformed Shape > 

KUND установить Def + undeformed > OK 

Некоторые символы пропадают. Восстановим их: 

U_M > PlotCtrls > Symbols > 

Boundary condition устанавливаем “All Applied BCs” 

> OK 

Форма стержня до нагружения (недеформированная) изображена сеткой чёрным 

цветом, форма после нагружения (деформированная) изображена цветными 

брусочками/элементами. Прогибается вверх и ввлево, всё правильно. 
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№ Действие Результат 

22 

Результаты пропечатывать в системе координат №11 главных центральных осей: 

M_M > General Postproc > Options for Outp > 

[RSYS] Results for Output установить “Local system” 

В окошке Local system reference no. указать 11 

> OK 

 

23 

Из всех узлов модели выделяем те, которые в заделке (то есть, имеют координату 

z=0): 

Выделяем узел с координатой z=0: 

U_M > Select > Entities… > 

В Select Entities установить “Nodes” и “By Location” 

Верхний селектор установить на «Z coordinates» 

В окошке Min,Max пишем 0,0 

Нижний селектор установить на «From Full» 

> OK  

Прорисовываем, что получилось:  

U_M > Plot > Nodes  



16 

http://www.tychina.pro/библиотека-задач-1/ 

№ Действие Результат 

24 

Усилия, с которыми элемент действуют на выделенные узлы: 

Точка отсчёта моментов (центр тяжести сечения): 

M_M > General Postproc > Nodal Calcs > 

> Summation Pt > At XYZ Loc > 

Селектор устанавливаем на Global Cartesian 

В окошке пишем глобальные декартовы 

координаты центра тяжести заделанного 

поперечного сечения (см. действие №6) 0,3,0 

> OK 

Показать все шесть усилий (три силы, три момента): 

M_M > General Postproc > Nodal Calcs > Total Force Sum 

LAB установить “Active RSYS” 

ITEM установить “ALL” 

> OK 

Внутренние изгибающие моменты равны: 

ZN 2F    ; 

XM 22   ; 

YM 14   . 

Точное совпадение с результатами аналитического расчёта (рис. 2). 

П р и м е ч а н и е: Иногда результаты получаются нулевые. Это сбой. 

Последовательно нажмите кнопки  и  и попробуйте ещё раз. 
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№ Действие Результат 

25 

Выделяем все податливые (из материала №1) конечные элементы и их узлы: 

Элементы: 

U_M > Select > Entities… > 

В Select Entities установить “Elements” и “By Attributes” 

Верхний селектор установить на “Material num” 

В окошке Min,Max,Inc пишем 1 

Нижний селектор установить на “From Full” 

> OK 

Их узлы: 

U_M > Select > Everything Below > Selected Elements 

Прорисовываем, что получилось:  U_M > Plot > Multi-Plots 

Автоформат – . 

 

26 

Цветовая шкала будет состоять из десяти цветов: 

U_M > PlotCtrls > Style > Contours > Uniform Contours > 

NCONT пишем 10 > OK 

 

27 

Напряжения будем смотреть на недеформированной форме: 

U_M > PlotCtrls > Style > Displacement Scaling > 

DMULT устанавливаем “0.0(off)” 

> OK 
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№ Действие Результат 

28 

Осевые напряжения в выделенном элементе: 

M_M > General Postproc > Plot Results > Contour Plot > 

Element Solu> Element Solution> Stress> Z-Component of stress 

> OK 

 

29 

Фронтальный вид: 

 - вид спереди;   - автоформат. 

Наиболее опасные точки поперечного сечения отмечены надписями MN и MX 

min B 1,08 ;     

max A 1,6 .2    

Точное совпадение с результатами аналитического расчёта (рис. 2.). 

Местоположения точек A и B совпадают. 
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30 

Настройка нелинейной цветовой шкалы: 

U_M > PlotCtrls > Style > Contours > Non-niform Contours… 

V1 пишем -1e6 

V2 пишем 0 

V3 пишем 1e6 

> OK 

Растянутая зона поперечного сечения окрасится в красный 

цвет, сжатая - в зелёный. Изменим палитру: голубой и жёлтый. 

U_M > PlotCtrls > Style > Colors > Contour Colors… >  

Contour Number 2 устанавливаем “голубой” 

Contour Number 3 устанавливаем “жёлтый” 

> OK 

Видим нейтральную линию (н.л.), отделяющую растянутые зоны друг от 

друга.Линия НЕ проходит через центр тяжести сечения. Качественно, по сетке 

элементов с размерами ячеек a a , можно отметить совпадение положения 

нейтральной линии здесь и на рис. 2. 
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Сохраняем проделанную работу: 

U_M > File > Save as Jobname.db 

Закройте ANSYS: 

U_M > File > Exit > Quit – No Save! > OK 

 

После выполнения указанных действий в рабочем каталоге остаются 

файлы с расширениями “.BCS”, “.db”, “.emat”, “.err”, “.esav”, “.full”, “.log”, 

“.mntr”,  “.rst”, ”.stat” и “SECT”. 

Интерес представляют “.db” (файлы модели), “.rst” (файл результатов 

расчёта) и файл “.SECT” (поперечное сечение), остальные файлы 

промежуточные, их можно удалить. 

 

 

 


