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B-09 (ANSYS) 

Формулировка задачи: 

Дано: Cтержень между двумя заделками. 
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Найти: эпюры  N , σ , ε , w. 

Аналитический расчёт (см. B-09) даёт следующие решения: 

 

 

 

3
F 75 кН

4
     N 

σ 

ε 

w 

а) 

б) 

в) 

г) 

д) 

1 q l   B G C D 

y 
F 

0  

0  

3
F 75 кН

4
   5

125кН F
4

   
② ① 

5
125 кН F

4
   

Рис. 1. 

C B 

y 

D K 

③ 

x 

F 100 кН  

1
F 25 кН

4
   

F 100 кН  

5 F
625 МПа

4 A





 1 F

125 МПа
4 A





 

5 F
0,003125

4 E A




 
 1 F

0,000625
4 E A




 
 

3 F
375 МПа

4 A


  


 

3 F
0,001875

4 E A


  

 
 

5 F l
1,25 мм

4 E A

 


 
 

7 F l
1,75 мм

4 E A

 


 
 

F l
1 мм

E A



 


 

 

Задача данного примера: при помощи ANSYS Multyphisics получить эти же 

решения методом конечных элементов. 
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Предварительные настройки: 

Для решения задачи используется ANSYS Multiphysics 14.0: 

 

 

 

Utility Menu (U_M) 

Main Menu 

(M_M) 

Рабочее поле 

ANSYS Command Prompt (C_P) 

Кнопка 

Fit 

 

C меню M_M и U_M работают мышью, выбирая нужные опции. 

В окно C_P вручную вводят текстовые команды, после чего следует 

нажать на клавиатуре . 

Меняем чёрный цвет фона на белый: 

U_M > PlotCtrls > Style > Colors > Reverse Video 

Скрываем пункты меню, не относящиеся к прочностным расчётам: 

M_M > Preferences > Отметить “Structural” > OK 

При построениях полезно видеть номера узлов и номера конечных 

элементов (один участок – один конечный элемент): 

U_M > PlotCtrls > Numbering > 

Отметить NODE ; 

Установить Elem на “Element numbers”; 

Установить [/NUM] на “Colors&numbers” 

> OK 

Для большей наглядности увеличим размер шрифта: 

U_M > PlotCtrls > Font Controls > Legend Font > 

Установить «Размер» на «22» > OK 

U_M > PlotCtrls > Font Controls > Entity Font > 

Установить «Размер» на «22» > OK 

Предварительные настройки выполнены, можно приступать к решению задачи. 
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Решение задачи: 

№ Действие Результат 

1 

Задаём параметры расчёта – базовые величины задачи (задаём): 

U_M > Parameters > Scalar Parameters > 

F=100e3     > Accept > 

l=0.4       > Accept > 

E=2e11      > Accept > 

A=200e-6    > Accept > 

Delta=0.001 > Accept > 

Iz=1e6      > Accept > 

nu=0.3      > Close 

Iz – изгибный момент инерции; nu – коэффициент Пуассона для металлов.  

2 

Таблица элементов: 

Первая строчка в таблице конечных элементов – плоский балочный тип BEAM3. 

M_M  > Preprocessor 

C_P  > ET,1,BEAM3 >  

Вторая  строчка  –  контактный элемент CONTA178: 

M_M > Preprocessor > Element Type > Add/Edit/Delete > Add 

Element reference number пишем 2 

В левом окошке выбираем “Contact” 

В правом окошке “nd-to-nd 178” 

> OK > 

В окошке Element types отметить вторую строчку “2 CONTA178” 

> Options > 

K2 установить “Penalty method” 

K4 установить “Real const GAP” 

K5 установить “Nodal coor - X” 

> OK > Close 
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№ Действие Результат 

3 

Наборы реальных констант: 

Сечение стержня площадью A: 

C_P  > R,1,A,Iz,l/10 >  

Жёсткость контакта и величина зазора: 

M_M > Preprocessor > Real Constants > Add/Edit/Delete > Add 

В окошке Element Type for Real Constants 

выбрать CONTA178 

> OK > 

 

 

 

 

 

 

В поле FKN пишем 1e3 

В поле GAP пишем Delta 

> OK 

 

 

 

Видим результат – три набора реальных констант в соответствующей таблице Real 

Constants. Закрываем таблицу: 

> Close 

 



5 

http://www.tychina.pro 

№ Действие Результат 

4 

Свойства материала стержня – модуль упругости и коэффициент Пуассона: 

M_M > Preprocessor > Material Props > Material Models > 

Structural > Linear > Elastic > Isotropic > 

EX пишем “E”, 

PRXY пишем “nu” 

> OK > 

Закрываем окно«Deine Material Model Behavior». 

 

5 

Координата X точек стержня: 

Определяемся с положением точек относительно глобальной декартовой системы 

координат. Начало отсчёта поместим, например, на левый край стержня, так 

привычнее. 

 

 

 

 

 

Рис.2 

 

 

 

 

l 

4·l 

y 

B x K’’ 

4·l+Δ 

3·l 

K’ 
C D 



6 

http://www.tychina.pro 

№ Действие Результат 

Конечноэлементная модель 

6 

Узлы 1, 2, 3, 4 и 5 в точках B, C, D, K’ и K’ соответственно: 

M_M> Preprocessor> Mоdeling> Create> Nodes> In Active CS > 

NODE пишем 1  

X,Y,Z пишем 0,0,0 > Apply > 

NODE пишем 2  

X,Y,Z пишем l,0,0 > Apply > 

NODE пишем 3  

X,Y,Z пишем 3*l,0,0 > Apply > 
NODE пишем 4  

X,Y,Z пишем 4*l,0,0 > Apply > 
NODE пишем 5  

X,Y,Z пишем 4*l+Delta,0,0 

> OK 

Справа от рабочего поля нажимаем кнопку Fit . 
 

7 

Скрываем оси системы координат: 

U_M > PlotCtrls > Window Controls > Window 

Options > 

[/Triad] установить “Not Shown” 

> OK 
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№ Действие Результат 

8 

Балочные конечные элементы (протягиваем по направлению оси X): 

Свойства участка стержня площалью A: 

M_M> Preprocessor> Mоdeling> Create> Elements> ElemAttributes> 

[TYPE]установить “1 BEAM3” 

[MAT ]установить “1” 

[REAL]установить “1” 

> OK 

Участки стержня: 

M_M > Preprocessor > Mоdeling > Create > Elements > 

> Auto Numbered > Thru Nodes 

Левой кнопкой мыши последовательно кликаем на узлы 

1 и 2 > Apply > 

2 и 3 > Apply > 

3 и 4 > Apply > 

> OK 

 

П р и м е ч а н и е: 

При клике на узел 4 может возникнуть 

окошко  “Multiple_Entities”, предлагающее 

уточнить – какой именно из близко 

расположенных узлов Вы хотите выбрать? 

Кнопками “Prew” или “Next” установите в 

нём “Picked Node is 4” и нажмите OK. 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

9 

Контактный конечный элемент в зазоре (протягиваем по направлению оси X): 

Свойства элемента: 

M_M > Preprocessor > Mоdeling > Create > Elements > 

> ElemAttributes > 

[TYPE]установить “2 CONTA178” 

[MAT ]установить “1” 

[REAL]установить “2” 

> OK 

Протягиваем контакный элемент между узлами  4 и 5, ограничивающими зазор: 

M_M > Preprocessor > Mоdeling > Create > Elements > 

> Auto Numbered > Thru Nodes 

Левой кнопкой мыши последовательно кликаем на узлы 

4 и 5 

> OK 

Прорисовываем всё, что есть: U_M > Plot > Multi-Plots 

 

10 

Проверка правильности протягивания конечных элементов между узлами: 

U_M > List > Elements > Nodes+Attributes  

Убеждаемся в том, что: 

а) Элементы протянуты последовательно между узлами 1 и 2, 2 и 3, 3 и 4, 4 и 5; 

б) Тип первых трёх элементов – 1 (это BEAM3), тип четвёртого элемента - 2 (это 

CONTA178); 

в) Реальные константы для балочных элементов – 1, для контактного – 2. 

Всё правильно. Закрываем информационное оконшко. 
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№ Действие Результат 

11 

Заделки: 

M_M> Preprocessor> Loads> Define Loads> Apply> Structural> 

> Displacement> On Nodes> 

Левой кнопкой мыши нажать на 1 и 6 узлы > OK > 

Lab2 установить “All DOF” > OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 

 

12 

Внешние силы: 

M_M > Preprocessor > Loads > Define Loads > Apply > Structural 

> Force/Moment > On nodes > 

Левой кнопкой мыши нажимаем на узлы 2 и 3 

> OK > 

Lab установить “FX” 

VALUE пишем F 

> OK 
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№ Действие Результат 

Расчёт 

13 

Запускаем расчёт: 

M_M > Solution > Solve > Current LS 

Синхронно появляются два окна: белое информационное и серое исполнительное. 

Белое закрываем, на сером нажимаем OK. Расчёт пошёл. 

Когда он закончится, появится окно «Solution is done!». Закройте это окно. 

Расчёт окончен. 
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№ Действие Результат 

Просмотр результатов 

14 

Силовая схема: 

U_M > PlotCtrls > Symbols > 

[/PBC] устанавливаем в положение 

“For Individual” 

Убираем галочку с “Miscellaneous” 

Surface Load Symbols устанавливаем Pressures 

Show pres and convect as устанавливаем Arrows 

> OK >  

В окне “Applied Boundary Conditions” 

  U установить “Off” 

Rot установить “Off” 

  F установить “Symbol+Value” 

  M установить “Symbol+Value” 

> OK >  

В окне “Reactions”  

NFOR установить “Off” 

NMOM установить “Off” 

RFOR установить “Symbol+Value” 

RMOM установить “Symbol+Value” 

> OK >  

Обновляем изображение:U_M > Plot > Elements 

В рабочем поле видим следующее: 

- Красным цветом начерчена внешняя сила; 

- Малиновым цветом начерчены реактивные силы  

Минусы означают направление векторов против оси X. 

 

Видим точное совпадение с результатами 

аналитического расчёта (рис. 1а.). 
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№ Действие Результат 

15 

Цветовая шкала будет состоять из десяти цветов: 

U_M > PlotCtrls > Style > Contours > Uniform Contours > 

NCONT пишем 10 

> OK 
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№ Действие Результат 

16 

Составление эпюры внутренней растягивающей осевой силы: 

M_M > General Postproc > Element Table > Define Table > Add >  

“By sequence num”, “SMISC,”, “1” 

> Apply > 

“By sequence num”, “SMISC,”, “7” 

> OK > 

> Close 

         

 

17 

Прорисовка  эпюры внутренней растягивающей осевой силы: 

M_M > General Postproc > Plot Results > Contour Plot > 

> Line Elem Res >  

LabI установить “SMIS1” 

LabJ установить “SMIS7” 

> OK  

Видим эпюру, состоящую из прямоугольников. Высоту каждого можно определить 

по его цвету, а можно посмотреть в виде списка: 

 M_M > General Postproc > List Results > Elem Table Data > 

Отметить мышью строчку SMIS1  

> OK  

 

 

Получаем тот же результат, что и на рис. 1б. с погрешностями менее процента.   
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№ Действие Результат 

18 

Составление эпюры осевого напряжения: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “LS,”, “1” 

> Apply >  

“By sequence num”, “LS,”, “4” 

> OK > 

> Close  

19 

Прорисовка эпюры осевого напряжения: 

M_M > General Postproc > Plot Results > Contour Plot 

> Line Elem Res > 

LabI установить “LS1” 

LabJ установить “LS4” 

> OK  

Видим эпюру, состоящую из прямоугольников. Высоту каждого можно определить 

по его цвету, а можно посмотреть в виде списка: 

 M_M > General Postproc > List Results > Elem Table Data > 

Отметить мышью строчку LS1  

> OK  

 

 

Получаем тот же результат, что и на рис. 1в. с погрешностями менее процента. 
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№ Действие Результат 

20 

Составление эпюры линейной осевой деформации: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “LEPEL,”, “1” 

> Apply >  

“By sequence num”, “LEPEL,”, “4” 

> OK > 

> Close  

21 

Прорисовка эпюры линейной осевой деформации: 

M_M > General Postproc > Plot Results > Contour Plot > 

> Line Elem Res > 

LabI установить “LEPE1” 

LabJ установить “LEPE4” 

> OK  

Видим эпюру, состоящую из прямоугольников. Высоту каждого можно определить 

по его цвету, а можно посмотреть в виде списка: 

 M_M > General Postproc > List Results > Elem Table Data > 

Отметить мышью строчку LEPE1  

> OK  

 

 

Получаем тот же результат, что и на рис. 1г. с погрешностями менее процента. 
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№ Действие Результат 

22 

Осевые перемещения сечений стержня (таблица): 

M_M > General Postproc > List Results > Nodal Solution > 

Nodal Solution > DOF Solution > X-Component of displacement> 

> OK 

Получаем окно “PRNSOL Command” с табличкой, где NODE – номер узла 

конечноэлементной модели, а UX – его перемещение по горизонтали. 

Погрешности вычисления перемещений узлов менее процента. 
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№ Действие Результат 

23 

Осевые перемещения узлов стержня (подготовка эпюры): 

Создаём массив-таблицу с названием, например, wtable : 

U_M > Parameters > Array Parameters > Define/Edit > Add >  

Par=”wtable” 

Type=”Table” 

I,J,K = 5,2,1 

> OK > Edit > 

Нумеруем столбцы и строки массива. 

 

Заполняем массив вручную. 

Первый столбец – координаты узлов по возрастанию, то есть координаты узлов 1
 го

, 

2
го

, 3
го

 , 4
го

 и 5
го

 (рис. 2). Второй столбец - перемещения UX узлов (см. результат 

действия №22). 

> File > Apply/Quit > Close 
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№ Действие Результат 

24 

Осевые перемещения сечений стержня (прорисовка эпюры): 

Параметры, необходимые для построения эпюры: по 

горизонтальной оси будет откладываться первый столбец 

массива, по оси ординат – второй столбец массива. 

U_M > Parameters > Scalar Parameters… > 

XN=1 > Accept > YN=2 > Accept > Close 

Сетка будет на обеих осях эпюры: 

U_M > PlotCtrls > Style > Graphs > Modify Grid > 

[/GRID] установить “X and Y lines”  

> OK 

Горизонтальную ось подписываем “L”, вертикальную ось подписываем “w”, 

интервал по горизонтальной оси устанавливаем от левого конца стержня до 

правого (0…2* l), а интервал по вертикальной оси таким, чтобы поместилась 

эпюра (0…0.001), см. рис. 1д.: 

U_M > PlotCtrls > Style > Graphs > Modify Axes > 

 [/AXLAB] X-axis label пишем L  

 [/AXLAB] Y-axis label пишем w  

[/XRANGE] установить “Specified range”  

XMIN,XMAX установить “0” и “4*l” 

 [/YRANGE] установить “Specified range”  

YMIN,YMAX установить “0” и “0.0018” 

> OK 

Прорисовываем эпюру: 

U_M > Plot > Array Parameters  

ParX установить “wtable(1,XN)”  

ParY установить “wtable(1,YN)”  

> OK 

 

Получаем ту же самую эпюру, которая изображёна на 

рис. 1д. 
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Сохраняем проделанную работу: 

U_M > File > Save as Jobname.db 

Закройте ANSYS: 

U_M > File > Exit > Quit – No Save! > OK 

 

После выполнения указанных действий в рабочем каталоге остаются файлы с 

расширениями “.BCS”, “.db”, “.emat”, “.err”, “.esav”, “.full”, “.log”, “.mntr”,  “.rst” и 

”.stat”. 

Интерес представляют “.db” (файл модели) и “.rst” (файл результатов 

расчёта), остальные файлы промежуточные, их можно удалить. 

 

 

 

    

 


