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N-04 (ANSYS) 
Формулировка задачи: 

Дано: E, q, a, l, Iизг, Iк, ν=0,25  . 

Консольная многосвязная 

плоскопространственная рама из 

стержней постоянного поперечного 

сечения, наружена внешним моментом 

и одной распределённой силой. 

Найти: 1) Построить эпюры внутреннего изгибающего Mz и внутреннего 

крутящего Mкр моментов в поперечных сечениях стержней рамы; 

2) Вертикальное перемещение точки A: δA. 

Аналитический расчёт (см. N-04) даёт следующие решения: 

4 4

z yI
1

0,08333
12

I a a      - изгибные моменты инерции; 

4

к zI 0,141 1,692a I    - геометрическая жёсткость при кручении; 
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     Рис.1. 

Задача данного примера: при помощи ANSYS Multyphisics получить этот же 

результат методом конечных элементов. 
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Предварительные настройки: 

Для решения задачи используется ANSYS Multiphysics 14.0: 

 

 

 

Utility Menu (U_M) 

Main Menu 

(M_M) 

Рабочее поле 

ANSYS Command Prompt (C_P) 

Кнопка 

Fit 

 

C меню M_M и U_M работают мышью, выбирая нужные опции. 

В окно C_P вручную вводят текстовые команды, после чего следует 

нажать на клавиатуре . 

Меняем чёрный цвет фона на белый следующими действиями: 

U_M > PlotCtrls > Style > Colors > Reverse Video 

В меню оставить только пункты, относящиеся к прочностным расчётам: 

M_M > Preferences > Отметить “Structural” > OK 

При построениях полезно видеть номера точек и линий твердотельной 

модели: 

U_M > PlotCtrls > Numbering > 

Отметить KP, LINE ; 

Установить Elem на “No numbering”; 

Установить [/NUM] на “Colors & numbers”> OK 

Для большей наглядности увеличим размер шрифта: 

U_M > PlotCtrls > Font Controls > Legend Font > 

Установить «Размер» на «22»> OK 

U_M > PlotCtrls > Font Controls > Entity Font > 

Установить «Размер» на «22»> OK 

Предварительные настройки выполнены, можно приступать к решению задачи. 
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Решение задачи: 

Параметрам задачи, входящим в формулы (E, q, l, E, Iz) присваиваем значение 1. Тогда результатами расчёта будут 

коэффициенты перед формулами. Величину a задаём произвольно, она в формулы не входит. 

№ Действие Результат 

1 

Задаём параметры расчёта – базовые величины задачи: 

U_M > Parameters > Scalar Parameters > 

E=1           > Accept > 

q=1           > Accept > 

l=1           > Accept > 

a=l/20         > Accept > 

Iz=1          > Accept > 

Iy=Iz         > Accept > 

Ik=1.692*Iz  > Accept > 

ASect=1e6     > Accept > 

nu=0.25       > Accept > 

> Close 
 

2 

Первая строчка в таблице конечных элементов – балочный тип BEAM44: 

M_M  > Preprocessor 

C_P  > ET,1,BEAM44 >  

Посмотрим таблицу конечных элементов: 

M_M > Preprocessor > Element Type > Add/Edit/Delete > Close 
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№ Действие Результат 

3 

Реальные константы для элемента BEAM44: 

C_P > R,1,ASect,Iz,Iy,a,a,Ik >  

Посмотрим таблицу реальных констант: 

M_M > Preprocessor > Real Constants > Add/Edit/Delete > Close 

 

4 

Свойства материала стержня – модуль упругости и коэффициент Пуассона: 

M_M > Preprocessor > Material Props > Material Models > 

Structural > Linear > Elastic > Isotropic > 

В окошке EX пишем “E”, в окошке PRXY пишем “nu” 

> OK 

Закрываем окно «Deine Material Model Behavior». 
 

Основная система. Твердотельное моделирование: 

5 

Координаты узлов рамы: 

Создаём твердотельную модель в плоскости x-z. 

Определяемся с положением узлов рамы относительно глобальной декартовой 

системы координат. 
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№ Действие Результат 

6 

Изометрия: 

 - изометрия; 

  - автоформат (размер изображения по размеру окна рабочего поля). 

 

7 

Ключевые точки  A→1, B→2, C→3 и D→4: 

M_M> Preprocessor> Mоdeling> Create> Keypoints> In Active CS> 

NPT пишем 1 

X,Y,Z пишем    l ,0 ,0         > Apply > 

NPT пишем 2 

X,Y,Z пишем    l ,0 ,l          > Apply > 

NPT пишем 3 

X,Y,Z пишем   2*l ,0 ,l         > Apply > 

NPT пишем 4 

X,Y,Z пишем  2*l ,0 ,0     > OK 

Прорисовываем всё, что есть:  

U_M > Plot > Multi-Plots 

 - автоформат. 
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№ Действие Результат 

8 

Линии - оcи стержней рамы: 

M_M > Preprocessor > Mоdeling > Create > Lines > Lines > 

Straight Line > 

Левой кнопкой мыши последовательно нажать на ключевые точки: 

1 и 2 

2 и 3 

4 и 3 

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 

 

9 

Заделка в точке D: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Displacement > On Keypoints > 

Левой кнопкой мыши нажать на 4 ключевую точку 

> OK > 

Lab2 установить “All DOF”  

> OK 

Прорисовываем всё, что есть: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

10 

Cосредоточенный внешний момент: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Force/Moment > On Keypoints > 

Левой кнопкой мыши нажать на 1 ключевую точку 

> OK > 

Lab установить “MZ” 

VALU пишем -q*l**2 

> OK 

Прорисовываем всё, что есть: 

 U_M > Plot > Multi-Plots 

 

Конечноэлементная модель основной системы. 

11 

Указываем материал, тип элементов и номер поперечного сечения: 

M_M > Preprocessor > Meshing > Mesh Attributes > All Lines > 

[TYPE]   установить “1 BEAM44” 

[MAT]    установить “1” 

[REAL]   установить “1” 

> OK 
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№ Действие Результат 

12 

Размер элементов: 

Линии без распределённых нагрузок можно бить одним конечным элементом. Но 

форма изогнутой оси будет выглядеть красиво, если каждый стержень будет разбит 

несколькими элементами: 

M_M > Preprocessor > Meshing > Size Cntrls > ManualSize > 

Lines > All Lines > 

NDIV пишем 10 

> OK 

Обновляем изображение: 
U_M > Plot > Multi-Plots 

 

13 

Указываем, что именно нужно теперь прорисовывать по команде Multi-Plots: 

U_M > PlotCtrls > Multi-Plot Controls… >  

Появляется первое окно Multi-Plotting 

> OK > 

Появляется второе окно Multi-Plotting > 

Оставляем в нём отметки только напротив Nodes и Elements 

> OK 
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14 

Рабиваем линии на элементы: 

M_M > Preprocessor > Meshing > Mesh > Lines > Pick All 

Обновляем изображение: 

U_M > Plot > Multi-Plots  

 

15 

Переносим на конечноэлементную модель нагрузки и закрепления с модели 

твердотельной: 

M_M > Loads > Define Loads > Operate > Transfer to FE > All 

Solid Lds > OK 

Обновляем изображение: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 
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Распределённая нагрузка ·q: 

M_M > Preprocessor > Loads > Define Loads > Apply > 

Structural > Pressure > On Beams > 

Левой кнопкой мыши отмечаем 10 элементов поперечины 

> Apply > 

LKEY пишем 2 

VALI пишем q 

> OK 

Обновляем изображение: 

U_M > Plot > Multi-Plots 

 

Расчёт 

17 

Запускаем расчёт: 

M_M > Solution > Solve > Current LS 

Синхронно появляются два окна: белое информационное и серое исполнительное. 

Белое закрываем, на сером нажимаем OK. Расчёт пошёл. 

Когда он закончится, появится окно «Solution is done!». Закройте это окно. 

Расчёт окончен. 
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№ Действие Результат 

18 

Силовая схема: 

U_M > PlotCtrls > Symbols > 

[/PBC] устанавливаем в положение 

“For Individual” 

Убираем галочку с “Miscellaneous” 

Surface Load Symbols устанавливаем Pressures 

Show pres and convect as устанавливаем Arrows 

> OK >  

В окне “Applied Boundary Conditions” 

  U установить “Off” 

Rot установить “Off” 

  F установить “Symbol+Value” 

  M установить “Symbol+Value” 

> OK >  

В окне “Reactions”  

NFOR установить “Off” 

NMOM установить “Off” 

RFOR установить “Symbol+Value” 

RMOM установить “Symbol+Value” 

> OK >  

Обновляем изображение: U_M > Plot > Elements 

При необходимости корректируйте масштаб кнопками  или . 

Реакции в заделке хорошо согласуются со значением внутренних моментов в точке 

D на рис. 1. 

В рабочем поле видим следующее: 

- Красным цветом начерчена распределённая внешняя сила; 

- Синим цветом цветом начерчен распределённая внешняя сила; 

- Фиолетовым цветом начерчен вектор реактивного момента; 

- Малиновым цветом нарисована реактивная сила. 
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№ Действие Результат 
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Вид сверху: 

 - вид сверху; 

  - автоформат (размер изображения по размеру окна рабочего поля). 

 

20 

Цветовая шкала будет состоять из десяти цветов: 

U_M > PlotCtrls > Style > Contours > Uniform Contours > 

NCONT пишем 10 

> OK 

 

21 

Составление эпюры внутреннего изгибающего момента Mизг: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “SMISC,”, “6” 

> Apply >  

“By sequence num”, “SMISC,”, “12” 

> OK > 

> Close 

Смотрим таблицу результатов: 

M_M > General Postproc > Element Table > Define Table > Close  
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№ Действие Результат 
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Прорисовка эпюры Mизг: 

M_M > General Postproc > Plot Results > Contour Plot > 

Line Elem Res > 

LabI установить “SMIS6” 

LabJ установить “SMIS12” 

Fact пишем 1 

> OK 

Получаем тот же результат, что и на рис. 1. (только числа, выделенные синим 

цветом). Значения показывает цветовая шкала. 

Можете рисунок эпюры сделать крупнее: коэффициент Fact установите 2 или 3. 
 

23 

Эпюра на перекладине элементах: 

Прорисовываем: U_M > Plot > Replot 

Выделяем нужные конечные элементы: 

U_M > Select > Entities >  

Устанавливаем “Elements” и “By Num/Pick” 

Селектор на “From Full” 

> OK 

Кликаем левой кнопкой мыши на конечные элементы 

центрального стержня 

> OK 

Прорисовываем: U_M > Plot > Replot 

Видим часть общей эпюры на выделенном элементе. Значение показывают MIN и 

MAX. 

Выделяем всё, что есть: U_M > Select > Everything 
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№ Действие Результат 

24 

Эпюра на центральных конечных элементах: 

Прорисовываем: U_M > Plot > Replot 

Выделяем нужные конечные элементы: 

U_M > Select > Entities >  

Устанавливаем “Elements” и “By Num/Pick” 

Селектор на “From Full” 

> OK 

Кликаем левой кнопкой мыши на конечные элементы правого 

стержня 

> OK 

Прорисовываем: U_M > Plot > Replot 

Выделяем всё, что есть: U_M > Select > Everything 
 

25 

Составление эпюры внутреннего крутящего момента Mкр: 

M_M > General Postproc > Element Table > Define Table > Add > 

“By sequence num”, “SMISC,”, “4” 

> Apply >  

“By sequence num”, “SMISC,”, “10” 

> OK > 

> Close 

Смотрим таблицу результатов: 

M_M > General Postproc > Element Table > Define Table > Close 
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№ Действие Результат 

26 

Прорисовка эпюры Mкр: 

M_M > General Postproc > Plot Results > Contour Plot > 

Line Elem Res > 

LabI установить “SMIS4” 

LabJ установить “SMIS10” 

Fact пишем 1 

> OK 

Получаем тот же результат, что и на рис. 1. (только числа, выделенные синим 

цветом). Значения показывает цветовая шкала. 

 

27 

Прорисовываем конечноэлементную модель, возвращаемся к изометрии: 

U_M > Plot > Multi-Plots 
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№ Действие Результат 

28 

Форма деформированной упругой оси рамы под нагрузкой: 

Прорисовываем: U_M > Plot > Replot 

M_M > General Postproc > Plot Results > 

> Deformed Shape > 

KUND установить Def + undeformed 

> OK  

Это точная форма изогнутой оси.  

Для наглядности увеличиваем масштаб: 

U_M > PlotCtrls > Style > Displacement Scaling > 

DMULT устанавливаем “User specified” 

User specified factor увеличиваем в пять раз с 0.03904 до 0.2 

> OK  

29 

Выделяем мышью узел конечноэлементной модели, соответствующий точке A: 

U_M > Select > Entities… > 

В окошке Select Entities установить 

“Nodes” и “By Num/Pick” 

Точку селектора установить на «From Full» 

> OK > 

Левой кнопкой мыши кликнуть на точку A на деформированной 

форме. 

Кстати, при этом в окошке Select nodes припишется номер 

узла в этой точке «Node No. = 1» 

> OK 

Проверяем, действительно ли выделен узел с координатой X=1*l=1, Y=0 и Z=0 

U_M > List > Nodes… > OK 

Закрываем окно NLIST Command 

     

 

Узел в точке A 
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№ Действие Результат 

30 

Вертикальное перемещения узла №1: 

M_M > General Postproc > List Results > Nodal Solution > 

Nodal Solution > DOF Solution > Y-Component of displacement > 

> OK 

Пропечатались величины линейных перемещений узла №1: 

A

4

z

q l

E I
( 0, то есть вверх);1,2804UY   





  

Расхождение с результатом аналитического расчёта (рис.1.) составляет: 

0,9 %   
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Сохраняем проделанную работу: 

U_M > File > Save as Jobname.db 

Закройте ANSYS: 

U_M > File > Exit > Quit – No Save! > OK 

 

После выполнения указанных действий в рабочем каталоге остаются 

файлы с расширениями “.BCS”, “.db”, “.emat”, “.err”, “.esav”, “.full”, “.log”, 

“.mntr”,  “.rst”, ”.stat” и “SECT”. 

Интерес представляют “.db” (файлы модели), “.rst” (файл результатов 

расчёта) и файл “.SECT” (поперечное сечение), остальные файлы 

промежуточные, их можно удалить. 

 


